Subaru Forester Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Starting up the '09 tonight, it was about five below zero and the blower motor won't work. I can hear the relay clicking under the dash, just no motor at any setting. FWIW, I did hear some strange 'sloshing' noises from under the dash in that area yesterday, I wonder if some water got in there somehow and froze the wheel solid? I'm in the process of getting a hair dryer out there to warm things up to see if I can free it.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #3
Problem solved! I just stuck my space heater on the floor pointing it toward the blower motor and it freed it up after about 25 minutes. Probably got water in it after I put it in the ditch.
 

·
Registered
2017 Limited
Joined
·
1,018 Posts
Problem solved! I just stuck my space heater on the floor pointing it toward the blower motor and it freed it up after about 25 minutes. Probably got water in it after I put it in the ditch.
Haa, the ditch witch Foz. Water plus heater blower equals not good.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #7
I put it in a snow-filled ditch. Thought I was gonna tip it over - probably about a 45 degree angle on the pass. side. After I got it pulled out, all seemed well until I heard some 'sloshing' sounds from under the dash. I assume that some snow got in somewhere, and melted, and then subsequently froze after I shut it off. This was the final straw in my putting up with my all-season Geos. I was moving very slowly, and they just slid down into the snow, following the crown of the road.
 
1 - 7 of 7 Posts
Top