Subaru Forester Owners Forum banner

1 - 4 of 4 Posts
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I own a 05 XS with about 7500 miles on it. When I use the auto climate control for heat or defrost when it is roughly 40-45 degrees outside, the system blows hot air. Even with the temp control set at its lowest, the air is uncomfortable. I see no sense in running the defroster with a window cracked open. Is this a quirk in the system? Anybody else notice this? I've owned other cars with auto climate but haven't had this much of a problem. Thanks much...
 

·
Administrator
2018 2.5i Premium CVT
Joined
·
18,679 Posts
Welcome!

Ah, if we were back on the old site we'd politely suggest that you do a search, since this topic was discussed there at least a zillion times. But now we're starting clean with the new site, and there are no archives to search here.

Peaty once did an owner satisfaction survey, in which 71% of the responses were like yours.

The best solution known so far can be found at www.geocities.com/samiam_68/SubaruCCS/SSC_Fix.htm . It's so clever that it got written up in the New York Times.
 

·
Registered
2004 FXT
Joined
·
830 Posts
My CC has been acting all crazy lately.. I think the fan fix i created stopped working due to a bad connection.. will have to check it out.

It appears that Sam has sent Peaty an update... not sure if anyone knows, but check the link above on Scooby Mods... I will try the latest suggestion from Sam and see how that works out...
 
1 - 4 of 4 Posts
Top