Subaru Forester Owners Forum banner

1 - 13 of 13 Posts

·
Registered
2009 Forester 2.5XL
Joined
·
3 Posts
Discussion Starter #1
I got some problems with the AT OIL TEMP dash flash today (outside temperature 89F).
It went on more than a couple of times and the car (forester 2009 2.5XL 1384 miles) was shaking after that.
I stop the car for 15 minutes then I started and drove it for some miles and the ABS and AT OIL TEMP dash flashes were on again. Finally I called Road Assistance to pick up the car.
What is going on? Should I have to return the car to the dealer?
Please I need some help.
 

·
Registered
2003 Cross Sports
Joined
·
824 Posts
I didn't even know our cars had an AT temp light. My car didn't come with a manual. What's it look like?
 

·
Registered
2009 Forester 2.5XL
Joined
·
3 Posts
Discussion Starter #8
AT OIL TEMP

Back to the dealer immediately.

Welcome to the board :icon_biggrin:
Thank You!
Car is at the dealer since this morning.
They told me that there was an AT wiring problem?? … several parts were requested (arriving on Tuesday) and I should have the car back next Thursday.
It seems they want to change everything related to the AT wiring problem … any ideas? because I am completely lost!
Meanwhile enjoying the courtesy car until next week!
 

·
Registered
04 Forester X Auto
Joined
·
105 Posts
Thank You!
Car is at the dealer since this morning.
They told me that there was an AT wiring problem?? … several parts were requested (arriving on Tuesday) and I should have the car back next Thursday.
It seems they want to change everything related to the AT wiring problem … any ideas? because I am completely lost!
Meanwhile enjoying the courtesy car until next week!
Had the same problem with my wifes 09 Legacy. Car was sitting for a week at the dealership and initially when they pulled out the codes they told me that they never seen such code...

Turned out to be a faulty harness of AT temperature sensor. They had to call the other Subaru dealerships to find out how to deal with these codes.
I'm still not happy with this transmission. I had a 97 nissan maxima with 200k on it and the tranny felt better.
 

·
Registered
2009 Forester 2.5XL
Joined
·
3 Posts
Discussion Starter #11

Attachments

·
Registered
2009 Forester
Joined
·
1,163 Posts
I will check dealer's work order and will let you know tomorrow...

Make sure you contact Subaru of America regarding the issue you have.

BTW, do you live in Conroe, Texas???
 
1 - 13 of 13 Posts
Top