Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
1998 Forester 5-Speed
Joined
·
17 Posts
Discussion Starter · #1 ·
My mother has an 01 Impreza and this light has come on. She had it looked at by a transmission shop and first he said that it was a solenoid in the trans then said he replaced it and the car gave him the same codes. So he came to the conclusion that it was a resistor and referred her to another mechanic that said he fixed the problem and drove the car for 20 miles after a day of having the car back it came back on. Now he says its something under the dash. I was wondering if anyone has had this problem before? And if anyone has ideas of what could be wrong? Right now it's drivable, but at 60mph the rpm's are at close to 4000 as if it was stuck in 2nd gear.


Sent from AutoGuide.com Free App
 

·
Registered
2005 Forester XT AT
Joined
·
73 Posts
Did you get the code from either shop? I'm getting a tran code as well
(P1714 TPS power circuit) that is tranny specific meaning that my Cobb is unable to read it. Tranny shop read it for me and reset it. Helps if you know the code.
My symptoms are different though: at 60 or so the tranny wont stay in 4th. 4th and then 3rd and then 4th and then 3rd etc.
There are a ton of diagnostics for trannys. Lots a resistance tests on plugs and sensors.
I fear a non subie tranny shop not doing these tests and just shooting in the dark. As it seems is happening to you. I also fear a subie shop doing the same.

Sorry I have no real help for you except to get the code and do some digging here.
 
1 - 5 of 5 Posts
Top