Subaru Forester Owners Forum banner

1 - 2 of 2 Posts

·
Registered
2004 Forester XS Manual
Joined
·
1 Posts
Discussion Starter #1
Hi,
I have my ABS light stuck on my Forester.
I read the codes from the ECU using a standard ODB, and there was a wheel error somewhere.
I can't remember which exactly, but I cleaned the wheel sensors and checked the voltage changed on each one when the wheel was spun. Everything checked out OK. I have cleared the error, but I still get the ABS light on all the time, only briefly going away when you start the car for a second.
I tried using FreeSSM but couldn't get it to talk. I have a tactrix 2.0 (which I read doesn't work, you need th older one) and a VAG-COM which should have worked but did not. I'm not sure that freeSSM can read ABS codes anyway?
I tried using the pin short to show LED codes but my connector does not match what is shown in the pictures I have seen. The only free test wires are attached to the ABS diag port near the ODB port. I couldn't find which pin to jumper?
Is there a way on the 04 Forester to show the ABS blink codes?
I have already fixed a lot of stuff in this car and this is the final thing to get it on the road, but I'm stuck on this problem.
On a side note the o2 sensor heater showed a failure on bank1 so I replaced it, but it still comes up again when the car is cold, although I am getting a valid reading of the fuel mixture on the ODB interface.



Thanks.
 

Attachments

·
Registered
2005 Forester AutoTragic
Joined
·
22 Posts
Judging by your connector, no way to read abs codes via jumper method. Forget voltage, have you checked resistance of the seonsors at the connector??? You should be between 1meg ohm and 1.5meg ohm.
 
1 - 2 of 2 Posts
Top