Subaru Forester Owners Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I know it's been discussed before but...

I have an 03 forester. It came from the lot already in valet mode with no keyfob so I bought one from ebay. The security light blinks twice and the turn signals work. But the car does not respond to the programming steps. Is it possible to program the new keyfob while the car is in valet mode?
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,070 Posts
Not sure, you say the light blinks twice but this site:

Subaru Keyless Entry, Security Alarm, Immobilizer Key, Remote Start Systems. Most years and models

Says valet blinks 3X quickly. Also are you saying the signals blink when you push a button on the remote?

or you could just need to keep trying

8. Program remotes: works on Alpine system.

Unlock all doors, foot on brake, all doors closed. Cycle key quickly but carefully on-off appr 10 times until the car honks one time.
Do not turn the key far enough to start the car, just to the 'on' position so the dashboard lights up.

When the horn honks, open and close the driver's door, press any remote button and that's it.
Program another remote? Quickly open and close the driver's door again and push a button on the 2nd remote. That's it.

When you're done, remove the key and the horn should honk 3 times. You're all set.
Sometime it takes more than 10 on-offs to set program mode. Open/close the door, lock/unlock etc, wait 10 minutes, then try again.
 

·
Registered
2003 Forester
Joined
·
2 Posts
Me too!

EXACT same problem here - 03 Forester, bought used with the light flashing in the Valet Mode pattern, no key fob, bought a new one on eBay last week, have been endlessly following the directions and never hear the honk that would tell me I'm in Programming Mode, no obvious button pressing is helpful. I had two other people try it too, so it isn't just me. I think I am going try disconnecting the battery next... unless someone has a better idea? I'll keep you posted if I find out something interesting.
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,070 Posts
When you disconnect the battery and reconnect my guess is it will put the alarm in the on mode again. When that happens your alarm might go off. Then you need to have the key. put it in the ignition and turn it on and off 3X (all the way on I think like you are trying to start the car) and it should turn off. Hopefully then you can program in your fob. Let us know what happens.
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,070 Posts
Strange, I'm curious to know what they say.
 

·
Premium Member
2009 Outback XT-B 5MT
Joined
·
10,241 Posts
Because your profile doesn't say, and any help from us would have been useless if, say, you had a UK car. The alarm system on them is entirely different than the US variant.
 
1 - 11 of 11 Posts
Top