Subaru Forester Owners Forum banner
1 - 6 of 6 Posts

·
Registered
2004 Forester XS 5MT
Joined
·
6 Posts
Discussion Starter · #1 ·
I believe I have a strange issue going on with my '04 XS Premium. I've noticed that when I am running the HVAC system, at any temp, mode, or fan speed, the A/C compressor comes on and runs. Mind you, the button for A/C isn't illuminated at all, and manually pressing the button on and then back off does not cure it. Does Subaru have a logic in the HVAC to run the A/C in cold weather to keep the system lubricated? I'm a master Nissan technician for a living, and this is stumping me.

TL;DR A/C runs all the time, what gives?
 

·
Registered
2003 Forester X Auto
Joined
·
947 Posts
If you're in any of the defrost settings, it will keep the A/C compressor running down to below freezing to help defog and keep system lubricated during the colder months.
 

·
Registered
Joined
·
323 Posts
I would assume he understands how the defrost function triggers A/C being a nissan master tech, they do the same thing.

I'd use a scan tool and see what information you can get. I've seen a/c pressure switches stick and cause the a/c to run 100% of the time regardless of a/c request.

Also I'd check the clutch itself to see if its getting a signal in the first place, could just be a seized clutch.
 

·
Registered
2004 Forester XS 5MT
Joined
·
6 Posts
Discussion Starter · #4 ·
Well the system cycles on and off regardless if it's in defrost mode or not, and only when the HVAC system is on. I'm going to do a bit of research today and see what the deal is and report back
 

·
Registered
2003 Forester X Auto
Joined
·
947 Posts
I would assume he understands how the defrost function triggers A/C being a nissan master tech, they do the same thing.
Yes, I got that too. Sometimes just need to jog the memory, so thought I would throw that out there and bump the post, as there were no replies.
 
1 - 6 of 6 Posts
Top