Subaru Forester Owners Forum banner

1 - 7 of 7 Posts

·
Registered
99 Forester S 5 Speed
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 99 forester s 5spd i have a surging idle but the only codes that i pull are p0108 and p0113 which are manifold absolute pressure sensor and air intake temperature sensor now my question to the community is i looked under the hood and i seem to have both a map and a maf......the map is on the front side of the passenger strut tower next to another brown sensor and the maf is on the intake. It really is killing my gas mileage, i sold my expedition to save gas and truthfully the expedition got better gas mileage. I dont know where to begin ive used starting fluid to check for vacuum leaks. Found that a vacuum was off of the canister by the passenger side of the firewall. Still a surging idle. It still has power but the gas mileage sucks and the surging idle is a bit annoying(especially in traffic). Also, i only saw 2 ground wires to the chassis from looking at the top of the engine bay, is there another ground for the transmission? My lights dim when the cars idle surges so figured it had something to do with the car grounds. Any help would be appreciated, i hate for my first post to be a question instead of a contribution to the society. Also there is no map on my intake manifold under the 2 and 4 sprk plg wires
 

·
Registered
2004 Forester XT 4EAT
Joined
·
1,322 Posts
Hi,
Sorry you 're not getting help...the older models get less and less attention.

EdIT: I'm going w/the MAF.

Car should be a MAF-based system and the '99 had a recall for the MAF. You can set up an account on the Subaru site and I 'think' it'll check for recalls...not sure if it still goes back that far though.

But it sounds like you have a vacuum or hose leak, IMHO. I'd be getting out the fine-toothed comb and checking it all out. Pull the air intake system, verify the PCV hoses and everything is plugged in. There is a purge valve under the passenger's side of the intake manifold, which has two hoses that could be suspect.

Don't buy new parts if you want to try a new MAP. Check out a local pull and save for the same parts from a simliar year Forester, Impreza, Legacy, or Outback ....Subies interchange on most engine parts.

I believe the IAT is IN the MAF on the '99+ models...older Subies didn't have one.

See the attached photo in the 1st post HERE for a good description of under the hood stuff.

GL,
Td
 

·
Registered
99 Forester S 5 Speed
Joined
·
5 Posts
Discussion Starter · #4 ·
thanks i havent been on here in a while, i changed the map since then and still havent found the problem i pulled the intake and checked all the hoses and found one of the vacuum hoses unplugged by the firewall on a black canister.....plugged it back in and erased codes and still same thing. My idle just keeps bouncing.
 

·
Registered
99 Forester S 5 Speed
Joined
·
5 Posts
Discussion Starter · #5 ·
also, recently got a code for the knock sensor as well waiting for it come in mail. it actually should be here today....i just want to get rid of this idle surge.....i want to put my header and exhaust on but i dont want to until i fix the idle surge. do you know how hard it is to watch your exhaust just get no use lol.....
 

·
Registered
2004 Forester XT 4EAT
Joined
·
1,322 Posts
And the MAF?

I'd also consider replacing the IAC valve w/another USED one.. I'm not sure if it's part of the throttle body or not on your '99. If it is, then I'd just get the complete TB from another Forester or Impreza w/the 2.2 or 2.5...or a '99 Legacy w/the 2.2 - should all be the same.

GL,
TD
 

·
Registered
99 Forester S 5 Speed
Joined
·
5 Posts
Discussion Starter · #7 ·
Its not part of the throttle body its a separate part.....I replaced it with one I took off of a working car with no idle surge and still the same thing on mine....
 
1 - 7 of 7 Posts
Top