Subaru Forester Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone,

I'm pretty new to the forum posting wise however, I've been utilizing for a while when troubleshooting. So today I have a legit issue that I can't figure out and I've tried everything that I've read on here so far.
So some background, yesterday I bought brake pads all the way around for my '98 Forester. Go to install today, get the right front caliper off, brake pads on, then I go to push the pistons flush in order to get it back on over the new pads. The pistons were stuck so I decided to bust the brake line loose and take the caliper off. So get the caliper off, pistons un-seized, caliper back on, now it will not bleed. I've tried everything from the 2 person pump the pedal method, to one of those hand pump bleeders. Still get nothing. I've gone under the dash and got the abs to cycle thru still nothing. Even took the caliper apart to make sure I didn't bust any of the seals. Finally decided to drive it down the road 15 miles or so and see if there was a change, still nothing. I'm pretty stumped does anybody here have any ideas.
 

·
admin
2019 3.6R & 98 Forester Atlanta, GA
Joined
·
7,254 Posts
If you guys would fill out your user CP's with your info it makes it easier for us to help out. I have all those parts in storage and would be glad to help trouble shoot if you are local.
 

·
Registered
2007 Forester XT 4EAT
Joined
·
16 Posts
Did you take out the bleeder screw and check it? I had one that was rusted shut on another car -- managed to work the rust off and clear up that hole and was back in business.
 
1 - 4 of 4 Posts
Top