Subaru Forester Owners Forum banner
1 - 6 of 6 Posts

· Registered
2019 MY20 Forester
Joined
·
26 Posts
Discussion Starter · #1 · (Edited)
hey everyone!

picked up my MY20 forester the other day, after driving a gen5 impreza for a while. it came with the smaller screen and just a single USB at the front.
in the impreza, when using android auto, i was able to use the navigation AND the phone would charge up as we drove to the destination. where as in the forester it appears to just hold the phone at the same percentage?

it looks like the front USB in the impreza charges at 1amp where as the forester is only 500mA???? i have the rear ports as well, and they charge at 1.4amps, has anyone noticed this with the forester?
is it something to do with the smaller head unit?

edit

Guess i should mention the phones
- S10 (various cables, which all work fine in the impreza) - charges at less than 500mA
- Iphone 11 Pro - charges at 1 amp?
 

· Registered
2019 MY20 Forester
Joined
·
26 Posts
Discussion Starter · #3 ·
How are you measuring the amps drawn?
I have 2020 premium and Galaxy S10. I've only tried the front charger and it is fast-charging as far as I know.

i'm measuring with a inline amp meter, i noticed it was charging slowly (not at all, just maintaining percentage) so i plugged in the amp meter to see what was going on. (somewhat similar to attached photo)

This is for the MU20 2.5i-L (Australia) which comes with the smaller head unit, and only a singly USB port at the front.


 

· Registered
2019 Forester Touring
Joined
·
324 Posts
Both my front and rear ports in my '19 Touring are labelled as 2.1 amps and my Samsung S9+ indicates' fast charging' (higher amperage) when plugged in. I suggest trying a different cable as well as verifying that 'fast charging' is enabled in you phone settings.

Rear:
527923


Front:
527924
 

· Registered
2019 MY20 Forester
Joined
·
26 Posts
Discussion Starter · #6 ·
This is what my front socket looks like, I've tried with multiple cables, it's the same with all of them. And as mentioned in initial post, it works fine in the gen5 impreza? But that has the larger head unit, and two USBs at the front.

Rear sockets appear to charge fine (they're labelled at 2.1amps, but charge at 1.4, but hey, that's probably normal). It's just this front socket that's annoying me, as when I'm driving I'd like my phone to actually charge haha

I wonder if I buy the larger Front head unit, and corresponding USB socket piece, if I'll get faster charging?

527925
 
1 - 6 of 6 Posts
Top