Subaru Forester Owners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi! Proud owner of the 2019 forester here. I nust noticed when putting it to Xmode, the roll (left/right) angle indicator appears. However in a very flat surface, it indicates +2degrees to the right (passenger side). The only way it becomes 0 is if the right side is elevated - but shouldnt this mean the angle should now be + on the left and not 0. Anyone experiencing this?

Btw car is empty, gas tank is near empty and no load. Thanks!
 

·
Registered
2019 Forester CVT
Joined
·
15 Posts
Hmmm... I'll check mine when the wife let's me near it. Could it have something to do with how it was initially zeroed? Meaning that when it was initialized, the vehicle was in a 2 degree incline. I'll be interested in knowing how that resolves itself.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I brought it to the dealer yesterday and the brand new ones all had 0 degrees tilt on the same flat surface. Mine still had +2 right side. They're waiting on wheel alignment specs from singapore to update their system, ill let you know how that goes.

I had the control arms and end links re torqued before too, could be that but im not sure.
 

·
Registered
Joined
·
71 Posts
Anybody else having this issue. Mine was fine for months but recently after work on my car was done, it has been displaying +5 to the right on level ground.. dealer did a bunch of test and all the modules tested correct for angle but the display was reading wrong, so Suburu tech told them to replace the display which seems odd since nothing else is wrong with it
 
1 - 6 of 6 Posts
Top