Subaru Forester Owners Forum banner

2019 - "vehicle settings" menu access (merged thread) - SOLVED!

9453 Views 12 Replies 8 Participants Last post by  btbamalaska
Programming instrument panel

I am having trouble accessing two menus for programming on my 19 Touring. One is called "Vehicle Settings" in the main combination meter cluster. The other is called the "second menu" for the display in the middle of the dash. Each contains several sub menus for programming. Otherwise I have been able to program things. However, "Vehicle Settings" does not respond and I cannot figure out how to even get to the "second menu". There are references to the second menu in the manual but not directions on how to get there.
1 - 13 of 13 Posts
If I recall properly, I accessed only when switched to Parking. Engine should be off. Long press on corresponding button when display says so.
I was going to mention the same thing, on the fiance's Nissan, certain menus could only be reached whilst the vehicle was parked or engine wasn't running.
Both my issues are now resolved. One was me not fully understanding the menu structure. The "vehicle settings" menu suddenly started working yesterday. do not know what earlier problem was. Sorry that I did not mean to start a new thread.

I guess I did not start a new thread. Just got to get used to how this works again.
"vehicle settings" menu access

Just after getting my 19 touring in December I posted on a couple of problems I had with the menus for the main cluster and center info cluster. A few days later I figured out my problem with the center cluster menus, and mysteriously I was able to get access to the "vehicle settings" menu that I had been blocked from. I posted that and someone marked my post as "solved." However, there was no real solution for why I was having trouble accessing the "vehicle settings" menu and now I again cannot access it. I can scroll through the menus to it. It is the 5th of 7 menus for the main cluster. When I pull the middle button to enter the menu, the screen returns to the overall menu entry position. I tried making sure all doors were unlocked and lights fully off to see it that was a problem and it made no difference. I noticed the manual said access to some menus was blocked while driving, so I tried it with the engine was running and it only showed three of the seven menus available. This menu includes settings for things like automatic door locking and lights staying on after turning of ignition. Anyone else having trouble accessing this menu.
See less See more
@nds no need to start another thread when you already have a thread on the same subject. It's better to keep all the troubleshooting in one thread. Your threads have been merged. :wink:

As to your thread being marked "SOLVED!", you posted this, so your thread was marked "SOLVED!":
Both my issues are now resolved. <snipped>
I've changed that to "Updated", since you wrote this on your recent post:
<snipped> there was no real solution <snipped>

['07 FSXT MODding Journal] ['03 X MODding Journal]
@nds Have car running in park. When you get to vehicle settings, 5, pull QUICKLY on the center button. A long pull returns you to the beginning.
  • Like
Reactions: 1
@jmw15 Thanks. With this and some persistence tonight I was able to make the changes I wanted.
@nds you wrote:
With this and some persistence tonight I was able to make the changes I wanted.
Would I be correct to assume your issue has been resolved? :confused:

If resolved, I'm going to change the "Updated!" to "SOLVED!", on your thread title.


['07 FSXT MODding Journal] ['03 X MODding Journal]
Yes, I believe we can now say resolved. Thank you.
  • Like
Reactions: 1
Well, found this thread while searching for a solution to this very problem. Doesn't matter if the car is on, off, on accessory, in park, in drive, on a hill, or on grass. Can't access menu 5 of 7 "Vehicle Settings". Very frustrating and proposed solutions are very much appreciated.
I’m also having the same problem. Dealer told me to do a factory reset but that did not work either. Help appreciated.
Sorry to tag on to a dead thread but I am having this issue and looks like two others here posted after it’s been considered resolved but there is really no solution offered here besides “I tried later and it worked”.
1 - 13 of 13 Posts