Subaru Forester Owners Forum banner

41 - 60 of 64 Posts

·
Registered
2019 Forester Touring
Joined
·
36 Posts
Got Subaru email. Took 4 hours to finish download! 40 minutes to transfer to USB 3.0 thumb drive. Waiting until this weekend to try the install.
 

·
Registered
2019 Forester Limited automatic
Joined
·
61 Posts
Discussion Starter #42
Well, Subaru sending out emails is good. I was beginning to wonder if they would ever update the map database. Having a current map database is critically important.
 

·
Registered
2019 Forester Touring CVT
Joined
·
541 Posts
Out of curiosity, how many of you received an email from Subaru announcing the availability of this update?
The e-mail I got didn't come from Subaru of America, per se, it came from Subaru-Maps.com, I.E., the website you go to download the updater tool, which is run by Harmon. I'm assuming that only those of us that previously downloaded the Map Updater tool and registered it with our VIN#'s got an e-mail. No one should be expecting to get an e-mail from Subaru of America as I doubt they want to encourage non-tech-savvy owners trying to do this update themselves.

FYI, I just downloaded the update and it was 11.5 GB. Having a gigabit internet connection is nice, as that only took about 10 minutes.

I used a 16 GB Verbatim USB 3.0 flash drive in my USB 3.0 port and it only took about 15 minutes to copy to the flash drive. No problems at all with my computer seeing it. I'm off now to install it in my Forester.

For those having problems with flash drive compatibility, note that the Map Updater Tool user interface isn't totally intuitive -- it will suggest which drive to use but you still have to click inside the small radio button (circle next to the drive letter) to select it before it will let you click on the Start Installation button. (I realize some people are saying it doesn't even see the flash drive, but maybe this will help a few people.)
 

·
Registered
2019 Forester Touring
Joined
·
154 Posts
....
A brief check of the Subaru nav revealed some more problems. .... An attempt to use voice commands to navigate returned “Address search is not enabled for this country.” I wonder what country it thinks we’re in?
My 2019 Forester Touring has ALWAYS been saying this since I bought it! But only within the first 5 minutes or so after starting the car. After about 5 minutes, voice destination searching works fine. It seems like it needs to load a database or go online first or something. It's really odd, since the map screen shows my correct location immediately and I can search using the touchscreen. So it knows where we are and knows the POI's. Just can't search by voice. It does this every time I start the car for about the first 5 minutes. I had hoped that the latest map update might help with that, but it still does this.

Disappointing for sure! Fortunately I mostly use Android Auto anyway, and Google generally works better than the standalone navs anyway.
 

·
Registered
2019 Forester Touring CVT
Joined
·
55 Posts
I only get the "not enabled for this country" for the first 1-2 min after I turned the car on fresh in the morning. My guess is the GPS is calibrating for time and location.
 

·
Registered
Joined
·
359 Posts
I have installed Map Update Rel_UE.19.25.70 NAFTA and so far so good. It's definitely an improvement.

Positive changes:
  • Noticed some roads that were missing are now included!
  • Speed limits appear improved for accuracy and I noticed they removed speed limits on all non State and Federal secondary roads in my area. This is great because before it would almost always have the incorrect speed limits for secondary roads and side streets. At least now this inaccurate info is no longer displayed on screen! Love this change.
  • They supposedly fixed the issue where the Map screen would display say 55 MPH while the center speedometer cluster would show a mismatch of say 88 MPH posted limit.
Best update I've seen to date!
 

·
Registered
2019 Forester Touring
Joined
·
154 Posts
I only get the "not enabled for this country" for the first 1-2 min after I turned the car on fresh in the morning. My guess is the GPS is calibrating for time and location.
The software update for the head unit that was recently posted here fixed this issue, as well as other issues like the occasionally disappearing radio presets.
 

·
Registered
2019 Forester Touring
Joined
·
596 Posts
I have installed Map Update Rel_UE.19.25.70 NAFTA and so far so good. It's definitely an improvement.

Positive changes:
  • Noticed some roads that were missing are now included!
  • Speed limits appear improved for accuracy and I noticed they removed speed limits on all non State and Federal secondary roads in my area. This is great because before it would almost always have the incorrect speed limits for secondary roads and side streets. At least now this inaccurate info is no longer displayed on screen! Love this change.
  • They supposedly fixed the issue where the Map screen would display say 55 MPH while the center speedometer cluster would show a mismatch of say 88 MPH posted limit.
Best update I've seen to date!
I have also noticed your point #2...
 

·
Registered
2019 Forrester Touring CVT
Joined
·
112 Posts
I also have a touring that's been updated, no problems and I'm not 100% positive that it fixed the phonebook download issue. Sound is fine so far.
 

·
Registered
Joined
·
71 Posts
Everything worked for me on the download but now when I plug the usb drive in nothing comes up. Am I suppose to open a folder somewhere on the screen?
 

·
Registered
Joined
·
359 Posts
Everything worked for me on the download but now when I plug the usb drive in nothing comes up. Am I suppose to open a folder somewhere on the screen?
Nope, it should just come up with a popup asking for you to confirm or something you want to start the upgrade. This should happen as soon as you plug in the usb stick.

Or are you still talking about the PC part? If so there's an installer you need to run than pick where or what usb drive to install to.
 

·
Registered
Joined
·
71 Posts
Nope, it should just come up with a popup asking for you to confirm or something you want to start the upgrade. This should happen as soon as you plug in the usb stick.

Or are you still talking about the PC part? If so there's an installer you need to run than pick where or what usb drive to install to.
No the car part.. everything said successful on the pc side.. using San disk usb
 

·
Premium Member
2019 Forester Touring Automatic
Joined
·
239 Posts
No the car part.. everything said successful on the pc side.. using San disk usb
Some people have reported difficulty with certain USB makes. My install was successful with a Lexar USB flash drive. I don't know that the Sandisk drives are problematic, but that is a possible issue to explore.
 

·
Registered
2019 Forester Auto
Joined
·
27 Posts
Somehow I have lost sound from my rear speakers after the update Rel_UE.19.25.70 NAFTA
I have checked, the Fader is fine. I have done the factory reset, I have even pulled the battery from the car for a few hours, I have unplugged the cables from the amp below the passenger seat. I even brought it to the dealer where they were baffled. They told me both the rear speakers are blown and they will replace them. I know for a fact even blown speakers would make some noise, these are just not receiving a signal. I am confident it is a software problem. I don't want them to go through with changing the rear speakers as I worry when they take the doors apart they never put things back together nicely, I'm guessing I'll have door rattles and vibrations etc. Does anyone else have this problem? I didn't even notice the back door speakers were not working until I got driven home in my own car after a few drinks one night! Now it's driving me nuts.
 

·
Registered
2019 Forester Limited automatic
Joined
·
61 Posts
Discussion Starter #57
I received an email (2/25/2020) that a new software update was available. However, when I attempt to use the map updater; I get the message that it cannot connect to the server and to check the internet connection. The internet connection is OK as I can use a browser. Anyone else experiencing this issue?
 

·
Registered
2020 Subaru Forester Sport - Ice Silver Metallic, Option pkg 24.
Joined
·
265 Posts
Somehow I have lost sound from my rear speakers after the update Rel_UE.19.25.70 NAFTA
I have checked, the Fader is fine. I have done the factory reset, I have even pulled the battery from the car for a few hours, I have unplugged the cables from the amp below the passenger seat. I even brought it to the dealer where they were baffled. They told me both the rear speakers are blown and they will replace them. I know for a fact even blown speakers would make some noise, these are just not receiving a signal. I am confident it is a software problem. I don't want them to go through with changing the rear speakers as I worry when they take the doors apart they never put things back together nicely, I'm guessing I'll have door rattles and vibrations etc. Does anyone else have this problem? I didn't even notice the back door speakers were not working until I got driven home in my own car after a few drinks one night! Now it's driving me nuts.
Interesting... I had a glitch, where I was listening to XM radio and then received a message on my phone.. I then had siri read my messages on apple carplay and after it was done, my rear speakers was just humming a loud bassy sound. I had to shut the car off and restart it and it was back to normal.
 

·
Registered
2019 Forrester Touring CVT
Joined
·
112 Posts
Updated last night, I thought it went well, this morning I turned on the nav and it was spinning, saying NAV was loading. Went to get coffee and back and it showed the samething, so I decided to reinstall. Turned out that that had been a problem because this upgrade went smooth and when it was done the NAV was fine.

So if you're having issues, try to reinstall the update.
 

·
Registered
2019 Forester Limited CVT
Joined
·
14 Posts
I received an email (2/25/2020) that a new software update was available. However, when I attempt to use the map updater; I get the message that it cannot connect to the server and to check the internet connection. The internet connection is OK as I can use a browser. Anyone else experiencing this issue?
I get the same error message. I wasted about 4 hrs trying different things and never got beyond this error.
 
41 - 60 of 64 Posts
Top