Subaru Forester Owners Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2019 Forester Limited (No Nav)

I set "Clock adjustment" to "Auto".
My iPhone is connected via Bluetooth.
The phonebook is transferring.
But the clock is still 7 minutes slow!
 

·
Registered
2019 Forester Sport CVT
Joined
·
12 Posts
I asked about that when I took my vehicle in back in March for some service. I was told that feature was not currently enabled and that it would be enabled via an update in August. August came and it is still not working. Also, it would do a weird thing where where if I did try to sync up the date and time via Bluetooth, it would set the date back to the previous date.
 

·
Registered
2019 Forester
Joined
·
107 Posts
If you set manually - be aware, or it used to work this way, car assumes you are setting on 24 hour clock even when not set to that - so if you set in the PM and set to 2:00 it thinks you are setting to 2:00 am and thus doesn't set correct date the next day etc. I had to set clock to display 24 hour time, then set clock, and then change back to 12 hour. This was 6 months ago when I got car so I don't know if any updates have changed that but be aware (or set in the am).
 

·
Registered
2019 Forester, Touring CVT
Joined
·
126 Posts
@ronurb3 Try this. On your iPhone go into Settings -> Bluetooth then select the "i" to the right of for your vehicle. Then make sure "Show Notifications" is on (green). In the manual under setting the clock there is a note which reads.

NOTE - Depending on the model of smart- phone, the settings of the connected smartphone may need to be changed. (ex: For iOS or other models, notification settings may need to be activated.) For details, check the instructions on connecting smartphones.
 

·
Registered
2019 Forester Touring CVT
Joined
·
134 Posts
On my Touring, it took about 2 mins of drive time this morning for the clock to adjust for the daylight time zone change. It did it without any prompting from me
 

·
Registered
2019 Forester Sport Auto
Joined
·
86 Posts
I was trying to figure out why mine didn't change as it did when DST started in the spring. Well it turns out that the last update to the stereo system turned off auto time sync (can't remember what it's called for sure).

Sent from my SM-N970U using Tapatalk
 

·
Registered
2019 Forester Sport CVT
Joined
·
8 Posts
I set my clock manually yesterday as daylight savings ended. When I got in it to drive to work this morning it bumped back to the wrong time again... Ugh.. why is it so frustrating to do something so simple? I'll mess around with it more when I get home from work. I haven't checked for software updates lately so I'll probably start there. Mine is a sport currently with Software Version Rel_U1.18.38.50.
 

·
Registered
2019 Forester
Joined
·
107 Posts
Mine updated automatically when I reset the setting to auto on the vehicle (why it turned off who knows) as said in a prior message make sure bluetooth is set correctly on your phone
 

·
Registered
2019 Sport CVT
Joined
·
423 Posts
Mine on auto was setting it an hour fast. So I turned Auto off. Turned Auto back on this morning and it set the time 2 hours fast, so I turned Auto back off
 

·
Registered
2019 Forester, Touring CVT
Joined
·
126 Posts
This is from the manual about setting the clock to automatic.

Setting the clock automatically

1. Turn the ignition switch to “ON”.
2. Press the “Home” button.
3. Select “Settings”.
4. Select “Vehicle”.
5. Select “Clock adjustment” and then select “Auto”.
6. Press the “Home” button again to complete the setting.

Models with navigation system

The clock will be set automatically where a GPS signal is available.

Models without navigation system

The clock will be set and adjusted automatically when a smartphone is connected via Bluetooth® for transferring phonebook data.
1. Register the smartphone to the audio system. For details, refer to “Bluetooth SETTINGS” in the supplemental Owner’s Manual for the audio/navigation system.
2. Transfer phonebook data to the system. For details, refer to “Bluetooth SETTINGS” in the supplemental Owner’s Manual for the audio/navigation system. The clock will be adjusted automatically.
 

·
Registered
2019 Forester Sport CVT
Joined
·
142 Posts
I'm having the exact same problem, time will not update. This is what I don't understand and maybe along with Subaru's windshield lawsuit there should be one for entertainment system. Why do I need to enable and install all these apps for the most basic features to work, ie. add my phonebook contacts for the time to update..***. Or install Aha app to check for updates on the car, a music app, seriously or enable Siri to allow a USB connection. Bloody ridiculous, sorry OP, your post just hit a nerve. Thanks @gumbobtr I'll try your instructions.
 

·
Registered
2019 Forester, Touring CVT
Joined
·
126 Posts
I'm having the exact same problem, time will not update. This is what I don't understand and maybe along with Subaru's windshield lawsuit there should be one for entertainment system. Why do I need to enable and install all these apps for the most basic features to work, ie. add my phonebook contacts for the time to update..***. Or install Aha app to check for updates on the car, a music app, seriously or enable Siri to allow a USB connection. Bloody ridiculous, sorry OP, your post just hit a nerve. Thanks @gumbobtr I'll try your instructions.
Well, I hope this helps resolve your time issue. If you do not want the contacts to load maybe try it without the contacts and see what it does. Manually set the clock to an incorrect time and then follow the procedure and see what happens. I think the key is to turn on notifications within the bluetooth settings on the iPhone itself. I am not sure why this is required for time sync but it may be an IOS thing. I am not sure AHA is required for firmware updates. There is an option for over the air updates and I do not believe this requires the app. However someone stated that this is not available with non-Nav units. Mine has Nav so I do not know. And the point about the music app, I agree, nuts. I find it odd that I can use the head unit to play/control Pandora but I can not use it to play music on the phone via bluetooth. I did go into the Starlink app on the HU and and use the music player there but that was a big fail.
 

·
Registered
2019 Forester Sport CVT
Joined
·
8 Posts
I figured mine out after tinkering for a bit. My problem was in my Bluetooth settings on my phone like some others have suggested. I have an Android phone so it's slightly different than the iPhone. Specifically I have a Samsung Galaxy s10. If you press and hold to get into your Bluetooth settings, hit the gear next to your car's connection listed in the Paired devices. Make sure both "Contact access" and "Message access" are active. That change immediately reflected the time change when set to auto. Hopefully this will help some of us droid guys out.
 

·
Registered
2019 Forester
Joined
·
107 Posts
By the way - there are a couple of YouTube video's on setting the clock on 2018 Forester. Just search there
 

·
Registered
2019 Premium CVT
Joined
·
58 Posts
@ronurb3 Try this. On your iPhone go into Settings -> Bluetooth then select the "i" to the right of for your vehicle. Then make sure "Show Notifications" is on (green). In the manual under setting the clock there is a note which reads.
Thank you. Now works perfectly. Turning on "Show Notifications" did the trick.
 
1 - 17 of 17 Posts
Top