Subaru Forester Owners Forum banner
1 - 18 of 18 Posts

·
Registered
2017 XT Limited + Tech
Joined
·
496 Posts
Discussion Starter · #1 ·
My FXT has 3 more months before the 5 year warranty runs out, so I did a check with my OBDII reader just in case. The emission test showed EVAP "Not Passed". No CEL and the car runs great. What could cause this? No change even after running several hundred km. Will be taking in to the dealer before warranty runs out.
 

·
Registered
2010 X Limited, 2.5L NA, 4AT. Purchased as the second owner in 2020 with ~126K miles.
Joined
·
785 Posts
Are there any pending codes? If you have never replaced the fuel tank cap, now's a good time to do that.
 

·
Registered
2004 FXT 4EAT
Joined
·
1,079 Posts
For the EVAP to pass, it needs to have a certain number of drive cycles without errors to pass. (Sorry, don't know how many, last time I was having trouble with EVAP, it was > 100 kms).
When you clear your codes (or have disconnected your battery), or the "validation process" starts over again.

(this is to prevent vehicles with issues to get through the emissions testing by simply clearing the codes as you're driving into the building for your inspection)
 

·
Registered
2017 XT Limited + Tech
Joined
·
496 Posts
Discussion Starter · #8 ·
I have some archived codes that I unsucessfully tried to clear, but that was >300km ago. I had taken the XT through all ranges of speeds. No check engine lights. I also had used 2 different OBDII readers (Car Scanner and Blue Driver) with same results. I think a gas cap problem will throw a cel. Is 300km enough?
 

·
Registered
2012 Forester 4 speed auto
Joined
·
1,200 Posts
Ok. The Evaporation monitor hasn't run. That means the enabling criteria has not been met. You need 4 parameters. ECT and IAT need to be the same temperature. The engine must be cold started. 1 quarter to 3 quarters of gasoline in Tank. Engine temperature must exceed 150F. Hopefully, the monitor will then run.
 

·
Registered
2017 XT Limited + Tech
Joined
·
496 Posts
Discussion Starter · #11 ·
@Easy Fixer . All the conditions were met.
@bman400 . We used to have mandatory emission testing here so I am spared. But still something is not right. I need to correct this in case I sell the XT or relocate to US for example.
 

·
Super Moderator
2001 Forester S, 4EAT
Joined
·
3,511 Posts
@eelnod Having attempted to import in 2001 my 1992 Honda Civic unsuccessfully, depending on the differences not all vehicles purchased in Canada are eligible to be imported in the US without extensive modification. Things may have improved since that time. At that time Honda America needed me to spend $3000-4000 to have airbags installed in the 1992 Civic before they would issue me a letter stating the vehicle met US import requirements!
 

·
Registered
2012 Forester 4 speed auto
Joined
·
1,200 Posts
Run the engine at a steady speed and throttle, from a cold start and the monitor will run. I've seen it happen with the car on a hoist. Typically evaporation monitors run last after all the other monitors have passed.
 

·
Registered
2017 XT Limited + Tech
Joined
·
496 Posts
Discussion Starter · #18 ·
I will try to drive it daily for 2 weeks and then test it again. The car is running great otherwise. I have till January before I take it in to the dealership if the problem persists.
 
1 - 18 of 18 Posts
Top