Subaru Forester Owners Forum banner

1 - 10 of 10 Posts

·
Premium Member
2014 2.0 XT Touring High Torque CVT
Joined
·
701 Posts
Discussion Starter #1
My BSD light came on and won't go off.
The system has stopped functioning.
I went to the dealer and they said someone must have hit my rear bumper where the radar is located. My rear bumper doesn't even have a scuff on it. They said it could've been a light tap by someone parking behind me.
Really?!
I was quoted a price of $300 to recalibrate the sensors! (Highway robbery I tell ya!)

Any suggestions on what I can do?
 

·
Premium Member
2014 2.0 XT Touring High Torque CVT
Joined
·
701 Posts
Discussion Starter #3
@PearlWhite That's what I told them, but they said no.
How do I contact SOA? I'm assuming that's my next step.
 

·
Registered
Sahuarita, Arizona USA 2018 Forester Limited
Joined
·
2,334 Posts
800-782-2783 (800-SUBARU3)

Is your 2014 still under SOA warranty? Perhaps you bought an extended warranty.
 

·
Premium Member
2014 2.0 XT Touring High Torque CVT
Joined
·
701 Posts
Discussion Starter #5
Sorry, have to update my profile. I now have the 2017XT, so yes, def still under warranty.
Thank you, for the contact information.
It's a downright shame that we have to go thru hoops to get the service that we deserve.
 

·
Registered
2012 Forester X Auto
Joined
·
1,926 Posts
@Gdaddy721 Sadly, that's the new world of Subaru....
Subaru of America is at (856) 488-8500.
For some reason, talking to someone works better than sending an email.

Report the problem and the dealer to SoA.

You can tell them you plan of filing a complaint with the BBB.

Contact the better business bureau and file a complaint. Easy to do online.

You can also go to any dealer - not just the $$#% you bought the car from.
Get a second opinion. See what they say.
Keep good records of your paperwork from every visit.

If all else fails you have a great case for small claims.

Good luck.
 

·
Registered
2019 Forester Touring
Joined
·
845 Posts
My BSD light came on and won't go off.
The system has stopped functioning.
I went to the dealer and they said someone must have hit my rear bumper where the radar is located. My rear bumper doesn't even have a scuff on it. They said it could've been a light tap by someone parking behind me.
Really?!
I was quoted a price of $300 to recalibrate the sensors! (Highway robbery I tell ya!)

Any suggestions on what I can do?
My wife’s 2015 Outback has a TSB identifying bad rear bumper sensors. She got hers replaced under warranty. Check to see if there’s a TSB that covers your vehicle.
 

·
Premium Member
2014 2.0 XT Touring High Torque CVT
Joined
·
701 Posts
Discussion Starter #8
Thank you for listing all the steps to take.
 

·
Registered
2018 Forester XT Touring HT-CVT
Joined
·
577 Posts
Welp...add me to the list of people experiencing this issue. Didn't want to create a new thread so I figured I'd hop in here.

Drove my dad's 17 Forester and noticed the BSD/RCTA off light was illuminated from startup and would not respond to presses of the on/off button. I scoured the internet for solutions but the forums didn't have much. I did search for a TSB and did find that there is one affecting 2017 Foresters where the BSD radar sensors have to be replaced under warranty due to a communication issue with the installed modules. The TSB came out the day before we took delivery of this Forester so it was likely never applied. The TSB is 07-118-17R and there's a publicly available PDF on Google.

Looks like I'll have to bring it into the dealer to get it serviced. Hopefully they won't try to give me any BS about impact damage. There's 0 marks on the rear bumper and it has never to my knowledge hit anything before.
 

·
Registered
2018 Forester XT Touring HT-CVT
Joined
·
577 Posts
Just to update...brought my car in for the TSB fix and they had to replace the passenger-side rear radar sensor due to the error code that matched the TSB. Apparently they didn't need to change both modules though...just the one faulty one. The dealer had sloppy workmanship though and forgot to replace one of the clips attaching the bumper cover to the rear quarter panel so that was a bit annoying.
 
1 - 10 of 10 Posts
Top