Subaru Forester Owners Forum banner
1 - 3 of 3 Posts

·
Registered
2013 Forester XT
Joined
·
6 Posts
Discussion Starter · #1 ·
I installed the Maestro RR/SU1 combo which is working great as far as the newly acquired vehicle gauges/info is going but I am having trouble getting the existing rear camera to work. All I get is a black screen “no video signal”. I followed the install/wiring correctly and triple checked. I’m starting to think that the camera is not getting enough power from what I’ve read. Has anyone ran into the problem or have any suggestions? I’m no electrician but I’m handy enough to get it done myself but I don’t want to get in there and just start splicing and cutting wires without some clarification. I’ve heard of people getting the 12v to 6v converter but I know nothing about that as well. Is there an easy solution?

-New radio-Sony xav-210, maestro RR, SU1
-2013 forester with Bluetooth steering wheel controls
 

·
Registered
2018 Forester CVT
Joined
·
177 Posts
Looks like Dara at 12volt may have answered it at Subaru Forester 2013 Rear Camera not working -
I pretty sure the MRR should give you the 12 volts you may need a ground the cable.

I am getting ready to upgrade my 2018 but will wait till Super Bowl weekend when the weather gets a little better in my unheated garage; Saturday they calling for upper 30's and mid 40's on Sunday. I have all the cables ready the only freaky part is dropping the air bag to gain access that 10 mm bolt. I read somewhere to disconnect the battery for 15 minutes for full discharge. Unless some one has done this before let me know. The video I watched he just unhooked the two nuts and gently let it hang.

Lou Cioccio
 

·
Registered
Joined
·
1 Posts
@LouCioccio How'd you go with the install?
I'm having trouble as the wiring diagram indicates harness 'D' is to be plugged into the secondary factory harness, however of the 5 cables plugging into the factory HU, theres the main harness, a completely different secondary plug, one big jack, and two small square plugs.

The wiring diagram has no indication of what to do with any of the smaller ones, and the D harness does not match any of the plugs leftover
 
1 - 3 of 3 Posts
Top