Subaru Forester Owners Forum banner
1 - 4 of 4 Posts

·
Registered
2011 Forester automatic
Joined
·
17 Posts
Discussion Starter · #1 ·
2011 Forester that had no symptoms other than the check engine light (and others) came on which kills the cruise control (I commute).
Took it in, said it was the map sensor, replaced and light came on again.
Took it back in to dealer and they replaced the cannister valve...drove home, turned car off. Next morning check engine light on again.

I will call dealer Tuesday but anyone have an opinion? No symptoms, EXCEPT after the fix when I left the dealership it seemed to hesitate a few time when accelerating...I think it might be using more fuel but will need to do the math at next fill-up.
 

·
Super Moderator
2001 Forester S, 4EAT
Joined
·
2,961 Posts
Unless you can use your cell phone with an OBDII reader to read the "CEL" or take it to get a free read from Autozone. No one here can tell you or help you in any way....
 

·
Registered
2011 Forester Limited
Joined
·
100 Posts
I chased that cel on my 11 about a year ago. Scan said map sensor so replaced it. A couple hundred miles and on again. Replaced the first sensor , heat/ fuel, pardon my forgetfulness, not the oxygen sensor, and off it went. Couple hundred more miles and on again. Replaced gas cap and, knock on wood, it’s been good since. Try the$20 Subaru cap and see. Ron
 

·
Registered
2011 Forester automatic
Joined
·
17 Posts
Discussion Starter · #4 ·
Thank you, Ron. The gas cap was replaced but don't think it was a Subaru part so will get one ordered. Looked at the air filter today and while it doesn't seem too dirty will replace that too. VERY frustrating.
 
1 - 4 of 4 Posts
Top