Subaru Forester Owners Forum banner
1 - 7 of 7 Posts

·
Registered
2010 Forester
Joined
·
93 Posts
Discussion Starter · #1 ·
Hi all,

As you can see in the attached photo there are a few empty holes under the rear wheel arch - it's the same on both sides. It almost seems that there should be plugs of some form in there to bind the metal of the wheel arch to the plastic panel at the rear. When the car was in for a service recently my wife asked and she was told that they are for mounting mud flaps.

What have other 09/10 owners got there?

Cheers - Steve
 

Attachments

·
Registered
2010 Forester(sold 11/12) Manual
Joined
·
49 Posts
Hi all,

As you can see in the attached photo there are a few empty holes under the rear wheel arch - it's the same on both sides. It almost seems that there should be plugs of some form in there to bind the metal of the wheel arch to the plastic panel at the rear. When the car was in for a service recently my wife asked and she was told that they are for mounting mud flaps.

What have other 09/10 owners got there?

Cheers - Steve
I just picked my red 2010 Forester up today (like 2 hours ago) and I had the dealer put the "mud flaps" on it. They called it "Splash Guard Kit" with a part number of J1010SC020 and it does use the holes to mount...so there isn't anything open to water there (now). I think I'd be disappointed if there were holes.
 

·
Registered
2010 Forester
Joined
·
173 Posts
I have the 2010 2.5X and it has the splashguard kit installed but the holes are still present. I believe the holes are for the wheel arch kit that wraps around the entire fender opening. See the ettached pic.
 

Attachments

1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top