Subaru Forester Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2004 FXT 4EAT
Joined
·
779 Posts
Discussion Starter #1
No codes, no Service Engine soon light, no flashing cruise light. JUST the traction Control light.

Pressing the button on the left side of the steering column doesn't make it turn off. Clearing the codes doesn't help. I even tried disconnection the battery for 30 minutes. Still no difference.

A bit of history: I replaced a seal in the steering rack (the main shaft, where the steering wheel attaches was leaking). I did that without removing the rack completely, so I wouldn't have to get a wheel alignment done. Since then, the light has been on. It wasn't on before.

There's a sensor in the drivers side (left) wheel well that appears to be missing something. The sensor is located just above where the stabilizer bar attaches to the frame. I checked, and I don't see the same sensor on our 2009 X. I removed it and I don't see any additional warnings on the dash. (after starting the car, with the sensor removed)
Does anyone know what this sensor is called/what it's for? Is it related to traction control somehow?

Google doesn't seem to have ever seen the numbers on the sensor...
522380
522381
 

·
Registered
2004 FXT 4EAT
Joined
·
779 Posts
Discussion Starter #2
No-one?
If there is additional info I can provide, I'd be happy to do so...

I'm having my doubts that the dealership would be willing to tell my what's up by simply hooking it up to their scanner for free...
 

·
Registered
2004 FXT 4EAT
Joined
·
779 Posts
Discussion Starter #3
I must say that I'm rather disappointed that no-one has any ideas.

Out of desperation, I had a look in the dash to see if I could replace the bulb with one that no longer works. But the dash light are all LEDs soldered onto the board! I didn't want to remove the LED because it might affect other circuits...

I may have to cave and take it to the dealership...
 

·
Registered
2004 FXT 4EAT
Joined
·
779 Posts
Discussion Starter #4
I called Subaru and they said that that sensor is for the headlight leveling system. Totally unrelated to traction control.

After explaining the situation with the steering, the guy on the phone suspects that something has gone wrong with the Steering Angle Sensor. Not sure how... I guess it's possible I turned the steering wheel around multiple times, and even though the wheel is straight, it's turned 720 degrees one way (or something like that). Not sure if it's capable of detecting that...

Found this article..

After a quick parts search, it appears the one in the 09 is the cheaper one. But I can't imagine how I "broke" it. Maybe they can reset it.
 

·
Registered
2004 FXT 4EAT
Joined
·
779 Posts
Discussion Starter #5
SOLVED: Took it to the dealership. They reset the steering angle sensor and the traction control light is now going out after starting the car. They charged me 1/2 hour labour.


Note: If you've messed around with the clock-spring (which contains ribbon cables in a very specific layout, connecting to your steering wheel controls, horn and airbag) make sure that you follow the instructions on the front of it; Turn it all the way to one side, then turn it back 3 1/2 turns. Failing to do will result in the clock-spring self-destructing when you turn the wheel all the way... (Don't ask... it's repairable, but not fun. Don't want to talk about it)
 
1 - 5 of 5 Posts
Top