Subaru Forester Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So for the past month or so my 07 FXT has been having issues accelerating when it hits 3k rpms. I've changed the spark plugs, but nothing changed. It surges and you can feel the car bucking when it does it. Any help would be greatly appreciated.

Dont mind the CEL they're for the air pump.
 

·
Registered
non-subaru
Joined
·
911 Posts
Could be a plethora of things, imo.
I've seen a throttle position sensor do weird things like that but would be reluctant to suggest you replace that just to see what happens. I'm not big on swapping parts without evidence.
Instead, hook an OBD2* scanner up to the car and plot some PIDs like the TPS, Labda and both O2 sensors, for starters.

*If you don't have one, you can get pretty capable bluetooth enabled OBD2 readers for cheap (sub $30) on Amazon that allow you to plot data using a tablet or smart phone.
 

·
Registered
2007 FXT 4EAT
Joined
·
41 Posts
@Remco Thanks I've been logging data from a OBD2 reader & Torque pro. Throttle position is perfectly steady, the only thing changing under moderate and higher acceleration is timing.

The issue temporarily goes away when remapped with accessport, but it always creeps back.
 

·
Create Value
2004 FXT 5MT
Joined
·
258 Posts
Any mods to the car? Any codes being thrown? Could be so many things, but first guess is that sounds like a fuel delivery issue to me. When was the last time you replaced your fuel filter? Injectors are how old?
 

·
Super Moderator
2018 X3 M40i / 2016 X3 xDrive35i
Joined
·
1,622 Posts
If it's surging like this under light acceleration probably your AFR sensor (upstream), if it's doing it under heavy acceleration, probably your MAF.
 
1 - 6 of 6 Posts
Top