Subaru Forester Owners Forum banner

2007 - keyless entry stopped working? - SOLVED!

11069 Views 17 Replies 5 Participants Last post by  2.5x_sleeper
I disconnected my vehicle battery to access the left front headlight for replacement. After reinstalling the battery, the keyless remote no longer works. Another clue is after locking the doors with the door lock switch, the car no longer beeps once and flashes the parking lights when the door is closed. Total time with the battery disconnected was about an hour. I previously had the battery disconnected for a timing belt replacement for about 8 hours with no ill effects on the remote, so I was surprised when this happened. Any help is appreciated.
1 - 1 of 18 Posts
Hi I had a similar experience when I tried to upgrade my dome light and map light on my 19 Crosstrek, the keyless stoped working or flashing, so like you I first checked the fuses, for the center lock, there were fine, then I decided to check the fuses one by one, and I found one bad one 10amp which was ignition coil I think it was burnt, I changed that using spare in fuse box under the hood and that was it, kinda odd experience, also couldn't find a stick to remove them, weird too, so I used my Letherman which works great, hope it helps! Good luck!
1 - 1 of 18 Posts