Subaru Forester Owners Forum banner

2007 - ECUFlash and Tactrix OpenPort 2.0 - Read successful, says Rom Unknown?

3740 Views 3 Replies 3 Participants Last post by  HalTheVictorious
Hello folks.

I'm hoping there might be something simple I am missing here.

I have read the ECU with ECUFLASH successfully, but it comes up and says Rom Unknown.

I've tried various definition files I've found online, but nothing changes. I've reinstalled ECUFlash a few times as well.

Any suggestions?

Thank you for your time.
1 - 4 of 4 Posts
I have the same car (2007 Subaru Forest 2.5X AT) and the same problem.

Unknown rom in ECUFlash, and no definitions in RomRaider.

None of the "2007 Forester" definitions in the various forums flagging this problem work. Please help!
You may have to scour and search through RomRaiders forum to find an unofficial version of your ECU definition , the .XML file to add to your library since it may not be part of the official one. Some year ECUs are like that where you can datalog them just fine, but ECUflash wont recognize the ECU file type. Also, make sure you have the right ECU type selected in there as well. Some of those middle years are odd like that... for example i was trying to do some troubleshooting for an 07 2.5i hatchback a while back, and it would give me that same error with the ECU type selected to what i thought it should be. Out of curiosity, i chose anther type (i want to say it was 07+ STI or something) and it read and opened the file just fine.
I finally got it to work! I was able to identify the ECU ID in ECUFlash when it ran connected to my car computer (in the main window where it shows status / what's happening). I then did a search for the ECU ID, and came across a forum with definitions I thought I'd already tried. Nonetheless, downloaded again, followed the instructions (including made sure I had the 32 bit base file in the directory)....and it works!!!!

Good luck! Post here if it works for you.
1 - 4 of 4 Posts