Subaru Forester Owners Forum banner
1 - 5 of 5 Posts

·
Registered
2000 forester auto
Joined
·
45 Posts
Discussion Starter · #1 ·
Hello everyone it's been awhile since I've been on here but I recently purchased a 2006 Forester X automatic trans that needed the engine rebuilt. I have since replaced: head gaskets, timing belt, tensioner, all pulleys with the belt, water pump, new radiator & thermostat, upper and lower hose, new plugs &wires, new starter. I just had 4 brand new tires put on today and I'm still getting a flashing AWD light, no other light comes on but that. No codes at all are stored for the engine or trans. According to the manual the light only comes on when you have mismatched tires or improperly inflated tires. Having new tires on I'm at a complete loss and any and all advice is welcome before I sell it cause I have enough in it.... Thanks Ken
 

·
Registered
2007 2.5XT Limited 4EAT
Joined
·
343 Posts
Given that you have no stored trans codes it’s not likely to be the output shaft sensor on the transmission. Could be a faulty wheel speed sensor, they do fail and will set the ABS light. Every now and again when the conditions are right, rainy or very high humidity, my 07 will trip the ABS idiot light. I assume in my case that the potting on the back of a wheel speed sensor is letting moisture in. It always goes away after one ignition cycle or once the weather drys out a bit. I have never nailed it down due to the fact that without a Subaru scan tool or something like a Snap On Soulus, which I do not have ready access to, there is no way to access the ABS codes/data. I’m not sure if Subaru monitors ABS pump pressure, but your issue may be as simple as low brake fluid. Just a theory, but easy enough to check the fluid level. Or perhaps take the car to a dealer or a competent mechanic with a good scan tool to check the ABS system.
 

·
Registered
2000 forester auto
Joined
·
45 Posts
Discussion Starter · #3 ·
Thanks for your response I have no codes at all especially ABS, I'm not quite sure but I'm thinking maybe the TCU could be bad or going bad. I can drive about a mile before the light starts flashing.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
41,245 Posts
@06 fxt 130k I see this is your first forum post, so welcome to the forum from Oregon!

Note that @beecho2 last signed onto the forum 6 months ago. You might send him a PM - Private Message... not called a Conversation on this new site. If he's optioned to receive an e-mail notification you could receive a reply.

Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 
1 - 5 of 5 Posts
Top