Subaru Forester Owners Forum banner
1 - 3 of 3 Posts

·
Registered
2004 Forester 4 speed CVT
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all, I have an 2004 Subaru Forester with approximately 88k miles. Just a few days ago I found out the passenger side stop light is not working when the brakes are applied. The driver side and parking lights are working just fine. I pulled the stop light bulbs on the passenger side they are good. I replaced them anyway. The STOP light fuse #16 is good. I don't see any other issues or bulbs with an issue. All other accessories and controls are working just find. I even went a step further and pulled the rubber grommet behind the bulb socket, tested it with a light tester there is no power to the pin. Has anyone experience this issue? Any leads on what to do next is highly appreciated. Thank you in advance for your assistance.
 

·
Registered
2004 Forester 4 speed CVT
Joined
·
3 Posts
Discussion Starter · #4 ·
Update

@2.5x_sleeper problem solved!! I pulled the inside plastic panel behind the taillight. Finding the electrical connector that connects the power, the clip had came loose causing a bad poor connection. I was able to clip it back on and placed the connector on the clip that's fixed inside on the molding and done. Thank you again for the providing the diagram earlier.

 

Attachments

1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top