Subaru Forester Owners Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello all! So I have a bit of a issue I recently bought my 4the Subie, a 2004 forester xt 4eat. Now the problem is just as the title states when I hit my fog lamp switch it turns on the high beams instead of the fog lights. I did find a wiring diagram that shows the red and green wire goes to both the fog lamp power and the high beams. I have checked power to the fog light harness and have nothing on both sides I have also checked at the fuse and have no power at the fuse? However the relay still clicks on and off I’ve switched it with a known good one and
The green indicator on the switch itself is faint green not a bright normal green any thoughts ?
 

·
Registered
2005 Forester Automatic
Joined
·
495 Posts
Are you sure its turning on the high beams?

When I installed my LED lights, I initially installed them upside down (I think). In the process of figuring that out, this is what I *think* I know:

--- when the fog lights are on, the relays somehow turn the main beams to LOW beam, regardless of the column lever position.

--- at short distance, it can sometimes be hard to know if you are looking at high beam on the wall, or low.

-- if the fogs are on, you cannot get a high beam.

-- if you turn the fogs on, when in high beam, it will force them to low beam.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
@cdherman Yes I’m sure. I bought the car and original owner put in a hid kit. I put the normal hologen h1 bulbs in still nothing? Tested the circuit with my test light found that the high beams turn on if I hit the fog button. If I turn on the high beams and hit the fog light button nothing happens and vice versa, if I hit the fog light button and turn on my high beams nothing happens as the high beam is already on

I do however have dual beam led head lights with three prints but I also have a kit that came with the car that only has two prints for low beam basicly cutting out the high beam.

Looking over this diagram fuse 7 powers the fog lamp circuit.that goes to pin 19/rl wire in the fog light relay, which flows to the 20/wb wire to both fog lamps and then to ground. The only thing that I notice is the high beam relay is tied with the fog lamp relay via the rg wire but I’m at a loss. C80E822A-0B4E-4CC9-97F9-D4410114A88C_1557801335372.jpeg
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
37,591 Posts
@Bttlwgon here's your options, as I see it...

[1] If you can contact the previous owner, ask if this issues started with... was caused by the HID installation? Ask what wiring was changed or modified & where these changes were made?

[2] Remove the HID kit & restore the factory/OEM head lights to see if the fog light switch still turns on the high beam lights. All modified wiring needs to be restored as it came from the factory.

Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
@2.5x_sleeper thank you for replying to my thread i was patiently waiting for you lol. The previous owner stated that “if you put hids in the head lights the fog lights will work”. I have also put in the factory supplied bulbs to no avail. I am also familiar with the fact subarus use reverse polarity in there wiring when it comes to lighting. I have switched both headlights to hid (previous owner had left with the car.) that did not come with the 3rd pin for the high beams to work. Is it possible that the switch can ground itself Internally?

Also I have no power at the fog light harness?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I have solved this issue the short was the bulb in the fog light switch I pulled the switch out removed the bulb and now the fog lights work. I originally used this link on NASIOC for converting the cruise switch to use as another switch but just swapped the cruise and fog switch here is the link: also if your fog lights stop working and it turns on the high beams pull out the green bulb on the switch

GD Dash Switch Modifications: Bulb Replacement and Switching Buttons - NASIOC
 

·
Administrator
2018 2.5i Premium CVT
Joined
·
18,449 Posts
A good piece of detective work. Subaru's interconnection of headlight circuitry and fog light control circuitry has been the source of many mysteries.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Sorry just hopped back on and saw these replies and actually I used a mod I found on nasioc and I disassembled the cruise switch and fog switch and switched there innards. So basicly I made the cruise switch locking and the fog switch just press button. And now the fog lights work perfectly fine now with no issues.

And I used the link I posted above to get the idea especially when he/she said the switches are exactly the same except one locks and the little clip inside that can be removed

GD Dash Switch Modifications: Bulb Replacement and Switching Buttons
 

·
Registered
2004 forester xs
Joined
·
7 Posts
I am having this issue as well, just not to the solved point yet. I just installed LEDs in headlights and fogs. The fogs weren’t working, I removed the bulbs in the fog light switch, and the fogs started working. But they are working on high beam. Like bttlwgon said I have the fogs on, I’ll flick the high beam switch on, the fogs will turn off, but the main beam will stay.
This has been the best page so far to get any relief from this issue.
 

·
Registered
04 Forester XT 5MT
Joined
·
80 Posts
I'm going to have to try this, as I noticed the same issue after replacing headlights with LEDs about a week ago. I'm planning on replacing the switch bulbs with red LEDs, so I'll just do this when I do that.
 

·
Registered
2004 forester xs
Joined
·
7 Posts
I swapped back to halogen headlights and cleaned up the lenses. The LED fogs are working well with the halogen headlights. I’m sticking with this setup
 

·
Registered
Joined
·
2 Posts
I myself am having a similar issue, if I push the fog light switch my highs come on along with fog, then if I pull lever for pass or push forward for high it'll shut off the fog lights(no change in high/ low) but to get the fog lights to come back on I have to push the button twice(off then back on) and only if the lever is not in the high beam position. Now with some of the poking around I did I found one possibility could be that seems my headlights are led and the setup is made so fog is cut off with high beam that what happens is there's a back feed that affects led causing them to come on
 

·
Registered
JDM swapped 2004 Forester XT
Joined
·
29 Posts
@John302 I too am also having this issue as of today. and found the same info about the fog and hi-beam relays being tied together as the fogs go off when you engage the highs under normal operation. I reached out to the manufacturer of the led headlights I bought and they said that adding some resistors between the cars harness and the bulb may solve the issue. Currently waiting on their arrival.
 

·
Registered
JDM swapped 2004 Forester XT
Joined
·
29 Posts
UPDATE: for anyone still dealing with this issue, I was able to get a special adapter from the manufacturer of the LEDs I purchased which seems to separate the relays and solve the issue.
 
1 - 16 of 16 Posts
Top