Subaru Forester Owners Forum banner
1 - 8 of 8 Posts

·
Registered
2003 JDM Forester XT
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi there,

I have a 2003 JDM subaru forester XT EJ205 130,000KM (timing belt changed around 100,000KM). It jerks/bucks/bogs when under low/medium load acceleration between 1000-3200 RPMS, you can slightly feel it in 3rd gear but almost always happens in 1st/2nd gear. It started getting a lot worse since winter came (living in alberta canada) and it also got worse last winter. It never happens when the engine is still cold (first 5-10 mins) and gets progressively worse the longer the car runs. Before it started doing this it would always have a bit jerking/hesitation around 2500-3000rpms only in 2nd gear. Under heavy load the car goes great and the idle is perfect. It runs great when you get up to speed and is responsive. Engine light has came on 3 times in the last year but only for a matter of seconds, no codes were obtained. Another thing to note is that after driving for 20-30 mins with lots of stops and starts there is a bit of a burning smell

Things that have been done by shop/myself:
-fuel injector lab clean (10 mos ago) this seemed to help a lot but not fully
-new spark plugs (10 mos ago)
-new fuel pump/filter (recent)
-gas tank has been checked for rust/dirt (10 mos ago)
-MAF was checked (10 mos ago)
-Coil packs were checked (10 mos ago)

I have it booked in for the shop but the last time I brought it in I was out $1200 and the problem still wasn't fixed 100%.
 

·
Super Moderator
2001 Forester S, 4EAT
Joined
·
3,511 Posts
Front O2 sensor is usually used to controll A/F ratio. However during warm up cycle the ECU uses a preprogrammed A/F ratio instead of using O2 sensor. So I wonder if the O2 sensor is not working.

Have you collected live obdii data on this?
 

·
Registered
2003 JDM Forester XT
Joined
·
5 Posts
Discussion Starter · #8 ·
Tried pulling codes again except after driving on hot engine for a little while. Got the following 3 codes:
1. MAF sensor circuit low
2. IAT sensor high input problem
3. Camshaft position sensor B circuit signal fault bank 1

Going to try MAF/IAT(same part) then see if that fixes all codes.. Hoping code 3 will fix itself if the jerking stops
 
1 - 8 of 8 Posts
Top