Subaru Forester Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2003 Forester X MT
Joined
·
6 Posts
Discussion Starter #1
Hey guys im stumped on this one. I drive an 03 forester x abd anytime I hit my brakes my front drivers side doesnt release. I have replaced the caliper and bracket and the rubber brake hose. Ive noticed that as soon as I open the banjo fitting the brake releases as the fluid leaves. Im assuming something is letting fluid into the caliper but not back out. Im atumped right now any help would be appreciated.
 

·
Registered
2004 Forester XS 5MT
Joined
·
886 Posts
Possibly a bad caliper, was it a rebuild? Did you fully bleed the brakes?
 

·
Registered
2003 Forester X MT
Joined
·
6 Posts
Discussion Starter #3
I did bleed the breaks. Multiple times to male sure. I bought a brand new caliper. When i replaced the old one due to sticking pistons.
 

·
Registered
2004 Forester XS 5MT
Joined
·
886 Posts
I am not certain, but is there a proportioning valve as well, could be?
 

·
Registered
2003 Forester X MT
Joined
·
6 Posts
Discussion Starter #5
Would the x have one? It still has drums in the back and not discs. I'm a fairly novice do it yourself and ove never had to investigate one
 

·
Registered
Joined
·
249 Posts
with rear drums and front disc brakes, then yes there will be a force proportioning valve, , this may be that or a bad master cylinder , unless you got a defective caliper or wrong front hose
 

·
Registered
2003 Forester X MT
Joined
·
6 Posts
Discussion Starter #7
Any way to test the valve or cylinder pre replacement? The issue was happening before i replaced the hose and I thought that might be the culprit which is why I replaced it. With my luck I could have gotten a bad one or wrong one.

One thing I just remembered that might help is a few days before the brake seized I could feel it catching and if I hit the brakes hard once or twice it would stop. And by hard I mean nearly slamming them to the floor
 

·
Registered
2003 Forester X MT
Joined
·
4 Posts
Did you figure out why the caliper wasn't letting go? I am having the same issue. I put a used caliper and new rubber brake line on left front, bled brakes and all worked well. Changed rear drum brakes complete with drums, shoes, hardware and wheel cylinders. Bled brakes and left front wouldn't release. Thought the used caliper had failed so I purchased a rebuilt caliper with bracket. Installed it, bled all four and still same issue. If I release pressure through bleeder valve, caliper releases. So I don't think it's the caliper or pins.
 
1 - 8 of 8 Posts
Top