Subaru Forester Owners Forum banner
1 - 20 of 34 Posts

·
Registered
2003 2.0 xt
Joined
·
22 Posts
Discussion Starter · #1 ·
hi, i have a 2003 forester xt, iv just noticed that my airbag light has come on, dunno what has caused this, any suggestions what to look for to fix it?

many thanx
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,071 Posts
It's not uncommon for one of the plugs under the front seat has either gotten loose or dirty. Very first thing to do is find the harness under each seat (start with the drivers seat) and unplug then plug it back in. You can always find the airbag wires (SRS system) because they are bright yellow. Try that first and let us know.
 

·
Administrator
2016 & 2018 2.5i Premium CVT
Joined
·
19,801 Posts
I got nailed by this the other day. I had earlier been rummaging under the seat (to get my spray can of window cleaner to remove bird poop), so that's where I went first. The connectors were actually still together but apparently partially dislodged inside. One squeeze and all was OK.
 

·
The Modfather
2019 Impreza 5dr Sport - Manual
Joined
·
8,071 Posts
I keep one of those synthetic chamois in the car for bird poop. The rag stays damp in the plastic tube :)

I had the same thing happen to me, the light came on and I pushed on the harness and it went out. For good measure I just unplugged and plugged it back in.
 

·
Registered
2007 2.5X 5mt
Joined
·
943 Posts
It's not uncommon for one of the plugs under the front seat has either gotten loose or dirty. Very first thing to do is find the harness under each seat (start with the drivers seat) and unplug then plug it back in. You can always find the airbag wires (SRS system) because they are bright yellow. Try that first and let us know.
Lol same problem today after I shapooed my carpets. Didn't realize until I was 2 miles down the road and the ugly airbag light was looking at me. Looked under the seat and the vacuum pulled one of the connectors out. 2 sec fix.
 

·
Registered
2003 Forrester
Joined
·
4 Posts
Nice Fix!!! Thanks

It's not uncommon for one of the plugs under the front seat has either gotten loose or dirty. Very first thing to do is find the harness under each seat (start with the drivers seat) and unplug then plug it back in. You can always find the airbag wires (SRS system) because they are bright yellow. Try that first and let us know.
I have had this issue for about a year or more. Took it to three mechanics, no joy. All I had left was the dealership that $90 to look at the problem. I pushed the cables together at lunch today and the light went out!!! I think I see tears of joy on my wife's face!!!
 

·
Moderator
2004 Forester 4EAT
Joined
·
5,471 Posts
Okay, so I checked all the normal things. I unplugged all 3 plugs under the seats. (Why are there 2 under the driver's seat? I don't have power seats.) The light is still on. Is there a diagnosing proceedure beyond checking all the plugs? This car has had no accidents.
 

·
Administrator
2016 & 2018 2.5i Premium CVT
Joined
·
19,801 Posts
Did you really mean to say 'unplugged'?

This can also be caused by a disconnected or broken 'clock spring,' which is the flexible cable that connects electrical stuff in the steering wheel to the rest of the Forester. Does your horn work?
 

·
Registered
04 Forester X, MT
Joined
·
1,039 Posts
I have a 2004. There is a TSB on this. The connector under driver's seat has a higher resistance connection than the computer monitoring system thinks is OK. The airbags should still work. Repair involves getting a new plastic part of the connector (easy to bend/break) and VERY CAREFULLY applying just enough solder to one side of the metal terminals after removing them from the plastic connector to make a better connection. IMHO it is a more delicate operation than many newer techs could do successfully without some practice.

I think I found this on scoobymods someplace. The H/C I kept doesn't have full web address. The TSB number shown is 17-01-04 dated 8/12/04 applicable to MY 2003 and 2004 thru VIN 4*737367.
 

·
Registered
2003 Forester X
Joined
·
10 Posts
I have a 2003 XT and the air bag light came on last week. Read through the few posts about this problem on this site and checked the connectors under the front seats tonight. Unplugged both, sprayed them with some brakclean and plugged them back in. Started the car twice and voila, the light went out. I'll repost if the light comes back on. :icon_biggrin:
 

·
Registered
1997 Subaru Forester
Joined
·
40 Posts
i have a 97 forester (right hand drive):raspberry: and my airbag light keeps coming on, prob more than 50 % of the time,

have bucket seats in there, can only find 1 cable under seat drivers side, but could of been for an amp from previous owner, has a yellow and white connector going to nothing or do i need to get right under the carpet for a good look?,

will this fail me for my warrant of fitness?

any help cheers
 
1 - 20 of 34 Posts
Top