Subaru Forester Owners Forum banner

1 - 4 of 4 Posts

·
Registered
2001 forester
Joined
·
8 Posts
Discussion Starter #1
I own a 2001 non-turbo automatic transmission 2.0 liter forester. It has 104,000 kilometers on it. I recently had the oil changed, together with the oil filter, sparkplugs, airconbelt, and alternator belt. After I got it back, I noticed a throbbing sound when accelerating, with a perceptible vibration from the floor as I accelerate. This was not present before the oil change. Can anyone tell me what this could possibly be due to?
 

·
Registered
Joined
·
3 Posts
I own a 2001 non-turbo automatic transmission 2.0 liter forester. It has 104,000 kilometers on it. I recently had the oil changed, together with the oil filter, sparkplugs, airconbelt, and alternator belt. After I got it back, I noticed a throbbing sound when accelerating, with a perceptible vibration from the floor as I accelerate. This was not present before the oil change. Can anyone tell me what this could possibly be due to?
Make sure the oil filter they put on works for your car because Subaru oil filters have a higher bypass pressure and can cause thudding from what I’ve see online.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
39,439 Posts
@MichaelAAA welcome to the forum from Oregon!

Note that you're replying to a 14 year old thread & @pinoysubie last signed onto the forum 9 years ago.

Also...
For the best forum experience, we recommend completing your "Account Details". The optional information you enter there will display when members click "About" in your forum profile. You can also create a custom "Signature" that will display every time you make a forum post. The optional additional information you provide could mean getting forum member replies, or not.
Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 
1 - 4 of 4 Posts
Top