Subaru Forester Owners Forum banner

1 - 9 of 9 Posts

·
Registered
2000 Forester
Joined
·
3 Posts
Discussion Starter #1
I started having some trouble with my 2000 forester today.

It was running fine all weekend then today the check engine light came on while I was driving, and a few seconds later the engine died. The oil and emergency brake idiot lights also came on.

Now the car will start and idle for five or six seconds and then it will sputter and die. If I try to give it gas it will also die. While it is idling for those few seconds the check engine, oil, and ebrake lights are all on.

Any ideas what this might be or things I can look at to help diagnose this?

Thanks!
 

·
Registered
2001 Forester S
Joined
·
106 Posts
Weird. Hard to connect all the warning lights. Did one of your belts break or slip off a pulley? Are the connections to the battery good? Could the engine ground have come loose?

Did you retrieve the Diagnostic Trouble Code that caused the Check Engine Light to come on? That would be most informative since it coincided with the failure.
 

·
Registered
2000 Forester
Joined
·
3 Posts
Discussion Starter #3
Weird. Hard to connect all the warning lights. Did one of your belts break or slip off a pulley? Are the connections to the battery good? Could the engine ground have come loose?

Did you retrieve the Diagnostic Trouble Code that caused the Check Engine Light to come on? That would be most informative since it coincided with the failure.
I looked under the hood and the blets seemed fine. I'll check the battery connections, before i head back out though, how do I get the diagnostic code? do I need a special tool to do that?
 

·
Registered
05 FXT 5MT
Joined
·
255 Posts
You need an OBDII code reader. They can be had cheap at most any discount parts store and can likely be returned as well. It sounds like maybe the MAP sensor died, froze up or otherwise quit working.

Unplug it (should be on top of the manifold, to the right of the coilpak) and start it up. See if it continues to run. If so, get the code read so you can diagnose it.
 

·
Registered
2000 Forester
Joined
·
3 Posts
Discussion Starter #7
We took it in and it turned out to be the fuel pump.

Thanks for the ideas everyone.
 

·
Premium Member
2014 Impreza Ltd CVT
Joined
·
3,363 Posts
Thanks for posting back. Now your symptoms and fix are here for others to search for.
 
1 - 9 of 9 Posts
Top