Subaru Forester Owners Forum banner

1 - 3 of 3 Posts

·
Registered
1999 S-Turbo Manual
Joined
·
46 Posts
Discussion Starter #1
Hey guys,

My SF5 has a huge over-fueling issue.

The following items have been replaced and checked.

Spark Plugs replaced
MAF Sensor replaced
TPS Sensor replaced
3 Port Boost solenoid replaced
555cc Injectors (16600-AA170) replaced
Fuel Filter replaced
Fuel Pump replaced
Lambda checked

Masses of grey/black smoke under acceleration, stuttering and obvious power reduction.

Car runs a VF34 turbo and a few other mods including ECUTEK remap.

At a loss to figure out what else I could try. My nearest place that deals with ECUTEK is 80 miles away, and it will use half a tank of fuel to drive 10 miles!!!

One thing to note, when stationary and out of gear, the engine will rev nicely without any stuttering. So it appears to happen under boost only. So perhaps I have a leak somewhere?

Thanks guys.
 

·
Registered
2004 Forester XT Auto
Joined
·
104 Posts
It sounds like you might have a massive intake tract leak somewhere after the turbo, like a BPV stuck open (and not connected to the inlet?) or a hose that's failed or not all the way on. Can you do a compression and leakdown test?
 

·
Registered
1999 S-Turbo Manual
Joined
·
46 Posts
Discussion Starter #3
It sounds like you might have a massive intake tract leak somewhere after the turbo, like a BPV stuck open (and not connected to the inlet?) or a hose that's failed or not all the way on. Can you do a compression and leakdown test?
Thanks for that, I assume you mean intake side of the turbo rather than exhaust?

At least there are some more things to check now!

Thanks again :)
 
1 - 3 of 3 Posts
Top