Subaru Forester Owners Forum banner

701 - 710 of 710 Posts

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
38,750 Posts

·
Registered
2001 Forester
Joined
·
1 Posts
Great thread, my clock hasn’t worked in years. Popped it out and found two resistors hanging by a thread. Soldered them back in, works fine. Nice fix, thanks.
 

·
Registered
Joined
·
3 Posts
hello guys. My WRX clock currently doesn't work so I wanted to use this topic to fix it. But before being lent a solder gun, I wanted to check which solders had to be fixed. Based on visual inspection, both 300 seem to be OK, but the 510 doesn't. So I checked with a multimeter and it displays a ~51 Omhs value (and 30 Ohms for both 300). Would it mean that the problem is due to other components?

Thanks for your help!

532776
 

Attachments

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
38,750 Posts
@juchapel welcome to the forum from Oregon!

A bridged ohm reading is not accurate. Normally the resistor has to be removed from the circuit board, as other components it connects to will affect the ohm reading. No need go thru that hassle in this case.

As others have noted, reflow the iffy solder connections to see if that restores the operation of the clock.

Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 

·
Registered
Joined
·
8 Posts
Thanks for the instructions! was frustrated that clock wasnt working, and here we are with the solution.
received my soldering kit today and got to work. All fixed and functional. I feel like im a soldering expert! haha
 
701 - 710 of 710 Posts
Top