Subaru Forester Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 1999 Forrester. I am having issues getting it to pass inspection. From what I know the car has had an 2001 engine swap. The exhaust has two o2 sensors is this a 99 exhaust or 01?
 

·
Super Moderator
2007 Forester Sports XT 4EAT
Joined
·
35,937 Posts
@SUBICON I see this is your fisrt forum post, so welcome to the forum from Oregon!

Two O2 sensors is the norm. They're placed on either side of the CAT. The one closest to the engine is your upstream, or A/F - Air/Fuel sensor. The O2 sensor placed after the CAT is the downstream sensor. This O2 sensor is used by the ECM to monitor the efficiency of the CAT.

Also...
For the best forum experience, we recommend completing your "Account Details". The optional information you enter there will display when members click "About" in your forum profile. You can also create a custom "Signature" that will display every time you make a forum post. The optional additional information you provide could mean getting forum member replies, or not.
Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes I am a newbie to the forums and Subaru's got this car super cheap and now I know why. I love the car and have spent a considerable amount of money and time into her. I really want to bring it back to fruition but this damn sensor is hanging me up.

So the sensors on the 01 engine will work for whatever Subaru exhaust I throw on it???

How can I confirm the year of the engine???
 

·
Super Moderator
2007 Forester Sports XT 4EAT
Joined
·
35,937 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Po130 keeps popping up...just died exhaust leak .gas leak .filler pipe. And new front o2 sensor
 

·
Super Moderator
2007 Forester Sports XT 4EAT
Joined
·
35,937 Posts
Is that the only CEL code you have?

P0130 - O2 Sensor Circuit Malfunction Bank 1 Sensor 1
You have 1 bank with 2 sensors, so that CEL code is pointing to the front/upstream O2 sensor.

P0130 SUBARU Possible Causes
• Faulty Front Heated Oxygen Sensor Bank 1
• Front Heated Oxygen Sensor Bank 1 harness is open or shorted
• Front Heated Oxygen Sensor Bank 1 circuit poor electrical connection
• Inappropriate fuel pressure
• Faulty fuel injectors
• Intake air leaks may be faulty
• Exhaust gas leaks
More info here:
Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 
1 - 6 of 6 Posts
Top