Subaru Forester Owners Forum banner

1 - 6 of 6 Posts

·
Registered
1998 Forester
Joined
·
4 Posts
Discussion Starter #1
Moderators note - this is a merged thread, the original thread title was "Brake lights/tail lights issue?".
So got a 98 forester, when I press on the brake my left brake light come on, and my right turns on the running light. Then vise versa when I take my foot off the brake (right brake comes on, left running comes on)

not sure what would cause this, please let know if anyone Has a solution
 

·
Registered
2009 Legacy
Joined
·
668 Posts
Edit: just making sure but when you take your foot off the brake and the wrong lights turn on, I'm assuming you have your lights on, right?

Check the brake bulbs. The brake lights are supposed to have two connections and body. I suspect one of yours has just one connection and a body. It does weird things when you have the wrong type of bulb in the brake socket.
 

·
Registered
2004 FXT 4EAT
Joined
·
459 Posts
It's not supposed to be possible, but I've seen the dual-filament bulbs installed the wrong way. (so the tail-light comes on instead of the running-light)
(there are 2 "pegs" on the bottom of the bulb. The one peg is a little higher than the other and you're only supposed to be able to put it in the socket one way. But corrosion and/or worn out sockets will sometimes allow you to put it in the wrong way)
(the brake-light bulb and the tail-light bulb are combined in one bulb)

When you turn on your headlights,is the right side tail-light brighter than the other?

I've also seen things get wired incorrectly after an accident-repair...

(not claiming that this is the solution to your issue, just speculating...)
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
36,347 Posts
@TheOneGinger I recall reading there the trailer connector getting wet & corroding can cause some strange tail light operation. Even if you don't have a trailer hitch, that connector is stored under the cargo area floor where it can get wet.

Bobby...

['07 FSXT Member Journal] ['03 X Member Journal]
 

·
Registered
1998 Forester
Joined
·
4 Posts
Discussion Starter #5
Not the ground and not the bulb. Not the only electric issue I’m having though. If I turn my brights on, it’s about half as bright as my regular lights. And if I push on my breaks while the care in completely off, my stereo flickers on and off

Been slowly fixing electrical issues with this 98 I bought a few months back and I’m down to 2 issues left.

1. when I flick my brights on, they get dim and slowly get dimmer.
For some reason the brights icon in my dash is always on, wether they brights are on or off.

2. when the car is completely off, the keys are out and I put my foot on the brake, my stereo flashes on then turns back off.

fuses are good, all the grounds to the body are good. Not sure what to do.

And I’ve replaced the old burnt wiring in the headlights, still no changes.
 
1 - 6 of 6 Posts
Top