Subaru Forester Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi guys, , my forester 1997 stb auto started cutting out, but restarting straight away without the need to use key.
Would also run a bit rough as I throttle on but then run fine.

I've got a code of 23, 2 long flashes then 3 short flashes, so I presume that's correct...

Do these symptoms sound like a maf fault???

And does anyone have a sensor?? Number on it is 22680AA280, A36-613 R80.

If anyone has one of these, let me know as I'm in desperate need to get back up.n running...

Cheers in advance..

Paul
 

·
Premium Member
2004 forester sti
Joined
·
2,144 Posts
You could try unplugging it , and if its still the same it might give an answer, if its worse then its not the maf….. I would guess.
You don't say if you have mods in this area? standard?
 

·
Premium Member
2004 forester sti
Joined
·
2,144 Posts
Any Rainbows in the coolant ? any milky residue around the oil filler ? Any white/ blue smoke on start up ? or you could try pulling the plugs and comparing them ? you could also check for air leaks .
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Oil and water are ok, , and no smoke. did think vacuum leak to start with, but when it came up with code 23, , and then pulled the plug on maf and no change, I'd say it's got to be that..... just need to get hold of a replacement asap.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Yea, car starts straight away after its cut out, and seems to drive normally, until it happens again, but its random,
It was fine this morning going the 12 miles to work and back, only seemed to do it when running around town.
 

·
Registered
Joined
·
9 Posts
Id suggest getting a spare MAF anyway and switching every service. This was recommended to me by the late Jolly Green Monster. Import car parts sold genuine ones at a reasonable price.
 
1 - 10 of 10 Posts
Top