Subaru Forester Owners Forum banner
1 - 8 of 8 Posts

·
Registered
2014 Forester 2.5 Touring CVT
Joined
·
174 Posts
Discussion Starter · #1 ·
My Galaxy S3 connects easily and dependably with the navigation system - with one exception: messaging. When I connected my phone it downloaded my contacts (successfully) and then asked to download messages (which did not succeed). I've never been able to get the system inform me of messages or ask me to read them. Everything else works wonderfully - including Aha.

Any hints/tips?
 

·
Registered
2014 Premuim CVT
Joined
·
104 Posts
Try deleting the phone and set it up as a new phone. I had a simular issue with my galaxy note 3. We have the navigation version. My wife's s4 is also connected but so far her phone has never had any issues but mine occasionally does. In fact, the other day while we were both in the car, a mail friend of hers text her something sexual suggestive which the car immediately started reading out loud. Needless to say I wasn't happy about it. Don't sync up your phone if you don't want everyone in the car to here it. Lol.
 

·
Registered
2014 Forester 2.5i Lim CVT
Joined
·
282 Posts
I had a galaxy nexus, and now have an LG G2, and both worked well at first. The Galaxy Nexus always worked, but with the G2, it worked until I switched to the new Hangouts, which replaces the stock messaging, now I get notified, but it always says it failed to retrieve message if I try to have it read out loud. I may have to switch back to stock messaging.

When you connected your phone, did you get a prompt allowing access to phone book, and then messages, and did you click, always allow?

As others suggested, I would also suggest deleting the pairing on both the phone and the HU and start over and see how that goes.
 

·
Registered
2017 Forester XT Touring CVT
Joined
·
58 Posts
My Galaxy S3 is doing the same thing. Connects flawlessly for phone and audio, but the messaging is VERY hit or miss. I have actually got it to receive messages a couple of times but the majority it does not. I will try the repairing and see how that goes.

When it says "retrieving messages" it fails most of the time ... or takes about 3-4 minutes and the messages come through. Then, one day without fiddling with it at all and on a long drive, it announced I had a new message and played it for me. I really like the feature, but would like it more if it always worked!
 

·
Registered
2014 Forester 2.5 Touring CVT
Joined
·
174 Posts
Discussion Starter · #5 ·
I figured out a solution. On your phone, download "Bluetooth Auto Connect" and install. Select the following profiles:

Media auto
Call audio
Input device
Networking

Then, messaging will work. My car was able to download messages and play them.

Sent from AutoGuide.com Free App
 

·
Registered
2014 Forester 2.5 Touring CVT
Joined
·
174 Posts
Discussion Starter · #7 ·
Not sure I have it totally figured out yet. It worked the very first time I tried after installing that app, but didn't in subsequent attempts. I'm perplexed.

Sent from AutoGuide.com Free App
 

·
Registered
2017 Forester XT Touring CVT
Joined
·
58 Posts
I am puzzled as well. My message connection works about 25% of the time. I added the Bluetooth Auto Connect. Neat program and I like the profile and priority settings, but I don't know if it did anything for me.

If I get in my car, the phone connects no problem. But, if after a few minutes, I click "Messages", it first says "Messages not retrieved". If I click it again, it will say "Retrieving messages. Please Wait." ... and then it fails. It has worked a couple of times but most often it does not!
 
1 - 8 of 8 Posts
Top