Subaru Forester Owners Forum banner

1 - 20 of 137 Posts

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #1
Back in May A6n6d6y was helping me straiten the tune out on my car, and he helped me get to a reasonable tune to get me along until i get go out and get a professional dyno tune. While on Andy's tune I was getting around 18-20mpg mostly city, and sometimes upto 23mpg highway.

I got dynotuned in August and immediately after the tune i noticed a decrease in fuel milage that seemed to get steadily worse as time progressed till i was getting 11 - 12mpg. Eventually i was getting misfires & strange idling also. Turned out to be a busted injector.

I replaced ALL my witch Hunter 830cc injectors with expensive DW850cc injectors, got the car re-dyno'd with the new injectors, lost a couple horsepower and fuel milage still sucks something fierce, anyone have any thoughts as to why my fuel milage sucks so hard?

My tuner says he can't understand why my milage sucks so hard because there's nothing too drastically different between the tune Andy helped me with and the dyno tune I got later.
 

·
Registered
09 Forester 2.5X
Joined
·
704 Posts
You aren't starting your car in the mornings during the winter months, are you? I'm not gonna lie, I noticed my milage going down...but then realized that it counts against me when I let the car warm up in the mornings :)
 

·
Registered
2012 Mazda2 sloppy 5 with imaginary 6th
Joined
·
302 Posts
lol yeah same here... I noticed a good drop in mpg too.. DAMM COLD!!!!!!!
 

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #4
I've had a remote start on my car basically since it was bought in 2005 and I have always given my car atleast 10 minutes to warm up in the morning, with that said, I've never had such terrible milage. Last winter with the same injectors and engine mods i still pulled an average of 18 - 20mpg around town.
 

·
Premium Member
2004 FSTI automatic
Joined
·
2,643 Posts
Sorry for OT, but what was wrong with your WH injectors? Were they flow tested & "new"?
 

·
Registered
05 FXT
Joined
·
1,540 Posts
Especially if you doused that O2 sensor in gas for a while. But I also have to wonder if something else is up, that is somewhat odd.
 

·
Registered
2004 Subaru FXT MT
Joined
·
1,841 Posts
Did you go to a high stall converter? What did you do to the tranny? Did it happen about the same time you did this?

I'd be checking all of my sensors, and looking hard at the front o2...
 

·
Registered
2007 Forester
Joined
·
92 Posts
Not that this would fix it, but I would stop idling my car 10 mins every morning. Unless it is damn cold this is way overkill.
 

·
Registered
2004 forester xt
Joined
·
292 Posts
my guess would be an O2 senor, you wouldn't know if it went our either because you delete the code when you throw on the TBE and tune it, and once it goes out air fuel mixtures go to crap.

for instence, my integra. even with 1000cc injectors on a 10 psi tune gets a good 24 mpg around town... so on a 11 gallon tank you expect to get 240-250- and with all free way its 34 mpg, with mixed its 30mpg, i always do mixed driving mostly freeway so you'd think 300+ would be about right. well when my O2 sensor went out i was only getting 160-170 miles on a full tank of super with mixed driving...

its worth it to check it out really, if i'm wrong then you've still eliminated something and can consintrate on trying to find something else:)
 

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #11
maybe your front o2 sensor is going bad. do you have an egt gauge?
I replaced the O2 sensor in an attempt to fix the issue back in october with a brand new $160 OEM subaru sensor.

Did you go to a high stall converter? What did you do to the tranny? Did it happen about the same time you did this?
I've had the high stall converter for 3 years now, it cause my milage to drop from 290+ miles per tank to about 250 back when it was initially done.

Not that this would fix it, but I would stop idling my car 10 mins every morning. Unless it is damn cold this is way overkill.
I've been doin it for 3 years now, never had a problem, and i'd rather the car be plenty warm then slightly cold.

Sorry for OT, but what was wrong with your WH injectors? Were they flow tested & "new"?
They all suffered from minor leakage and a so/so flow pattern. But one of them totally took a dump after about a year.
 

·
Registered
none none
Joined
·
8,844 Posts
I replaced the O2 sensor in an attempt to fix the issue back in october with a brand new $160 OEM subaru sensor.



I've had the high stall converter for 3 years now, it cause my milage to drop from 290+ miles per tank to about 250 back when it was initially done.



I've been doin it for 3 years now, never had a problem, and i'd rather the car be plenty warm then slightly cold.



They all suffered from minor leakage and a so/so flow pattern. But one of them totally took a dump after about a year.
Torque converter might not be locking up? Is the car running right? Have you checked the A/F ratio? It could be possible that you have pre-engine fuel leak?
 

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #13
Torque converter might not be locking up? Is the car running right? Have you checked the A/F ratio? It could be possible that you have pre-engine fuel leak?
Yea based on my tune/dyno plot my AFR is perfect. The torque converter never really locked up except under light throttle on the highway.

Is there a major motor problem that could cause poor milage? Like a blown ring or head gasket or anything?
 

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #14
Is it possible my MAF is shot?
 

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #16
do you have a wide band you can read while driving ?
I do, but the way I have to hook it up in my car, i'd rather not mess with it in this weather, but according to my dyno sheets my AFR is dead on:

 

·
Registered
2004 Subaru FXT MT
Joined
·
1,841 Posts
can you datalog the front o2 if you don't want to mess with the wideband?

Check the other sensors while you are at it.

Of course, you can always do a leakdown/boost check/compression test if you are concerned with the health of your motor. If you have internal engine damage, of course this will effect mileage...
 

·
Registered
2005 Forester XT 4EAT
Joined
·
2,160 Posts
Discussion Starter #18
can you datalog the front o2 if you don't want to mess with the wideband?

Check the other sensors while you are at it.

Of course, you can always do a leakdown/boost check/compression test if you are concerned with the health of your motor. If you have internal engine damage, of course this will effect mileage...
Yea, I can datalog the front O2 sensor no problem, i'm not sure what other sensors to check though, my primary front O2 sensor was just replaced, and my rear O2 sensor was removed years ago. The only other thing would be my MAF, but i would think the tuner would notice that immediately.

I'm still kicking around a Compression and/or leak-down test. I had one done roughly a year ago and came up with 135psi or better in all Cyls, so I don't think that'd be an issue.

Actually I have a ZIP file of some very short logs i took a couple weeks ago when i experienced some bucking/high EGT's on the highway, they should give you a little idea of what my engine is doing at highway cruising speeds. The logs are so short because i was tryin to isolate the bucking issue.
 

Attachments

·
SUPERZILLA
2006 fxt
Joined
·
660 Posts
aside from an internal motor problem, some likley causes are:

1 your tune is going very rich under cruise conditions..not going to show on a dyno pull

2 your tune is going very lean under some mid to high load conditions causing the ecu to pull timing. which will cause you to step on the gas more to get power and/or causing it to revert the 'backup fuel table' which is very rich. (can't rember the name of the table it reverts to when IAM drop below the threshold point)
 

·
Registered
05 FXT
Joined
·
1,540 Posts
failsafe fuel map

Hadn't considered that as a possibility. Good to see you on here again andy. And the SZ55 is still pulling hard.
 
1 - 20 of 137 Posts
Top