Subaru Forester Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Trying to help a friend he left a light on in his 07 Forester overnight so he called AAA for a jump start. After the jump start the instrument cluster doesn't work. I have a feeling it's either a fuse or the battery is shot, but he took it to a shop and they told him they can't find anything he has to go to a dealer for diagnostics. I don't trust the shop, but is there anything else we can test to avoid going to the dealer?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
suddenly everything turned back on after picking the car up from the shop. I continue to suspect it's the battery even though the shop claims it's good.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
38,953 Posts
@iizbor3d I see this is your first forum post, so welcome to the forum from Oregon! :biggrin:

My guess, the electronics glitched when the battery was drained, jumped & recharged. A system reset could have restored it, but no matter now as it's working now.

I'm going to add "SOLVED!" to your thread title. :wink:

Also...
For the best forum experience, we recommend completing your "Public Profile". Specifically, the "About Me" section (Edit Your Details). This displays every time you make a post on the forum. This will provide information members may need to reply to your forum posts. You can edit this field via the "User Control Panel", aka, "User CP.

If you're using a mobile device, you may need to use a laptop or desktop computer to see all the user tools.
Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 
1 - 3 of 3 Posts
Top