Subaru Forester Owners Forum banner

1 - 12 of 12 Posts

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #1 ·
Tried to swap my 04 xt seats for a set of heated wrx
seats today and found that my car has no plug for the air bag under the seat. The new seat has three plugs and my seats have two with a wiring harness that disappears under the carpet? Supposedly they were plug n play. What am I missing?
Thanks!
Dave
 

·
Registered
2004 Subaru Forrester XT
Joined
·
18 Posts
Sounds like the car wasn't pre-wired for heated seats. If the heater harness isn't there, you'd need to source one. Wiring it would require a good deal of panel removal.
 

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #3 · (Edited)
The current seats are heated. The problem is there doesn't appear to be a connector in the air bag wire. I'm assuming it's the one with the bar code. New seat (05 wrx) has a connector just below the bar code tag. Car appears to be hard wired to the seat with no connector. I know makes NO sense. So where is the connector in my 04 air bag wire?
 

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #4 · (Edited)
This is what I'm looking at
Notice the yellow wire goes into the loom with no connector. The top end goes into the seat near the belt, just like the new seat. The bottom end disappears under the heating ducts and carpet. It splits, one side going to the tunnel, the other going out toward the door. I know there's a connector somewhere but I don't want to start tearing stuff apart and be going in the wrong direction.

 

Attachments

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #5 ·
This is what the new seat looks like. I expected there to be a plug in the middle of the loomed wire on the old seat that matched the yellow plug on the new seat. How do I get the old seat out of the car!?

 

Attachments

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,109 Posts
Perhaps someone removed the connector & spliced the wires together? :confused:

You might carefully unwrap the black electrical tape above the yellow tape to see if there's a splice hidden there.

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #7 ·
Both seats appear to be wired this way but certainly is a possibility. As far as I know they are original :confused: Looks like its just two wires but it would probably be bad news to get them backwards. Hopefully if they are spliced the colors make sense
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,109 Posts
There were issues with faulty connectors causing an airbag light... usually caused by feet under the seat. Perhaps what you have is someones fix? :icon_eek:

There are connectors on my son's '03 X & my '07 FSXT. We installed STi seats & the airbag was plug & play.

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #9 ·
Figured it out.... Sort of. Someone did indeed cut the plugs off. Now I want to restore the car side so I can plug in my "new" seats. Its only two wires but I want to be sure to orient them correctly. Its a 50/50 X2. Fortunately I only need to re-do the car side.
I havn't been able to look too closely but so far the wires just appear to be yellow on both sides with no striping or other identifiers. Any suggestions?
THANKS!
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,109 Posts
The wire colors appear to be YG - yellow-green & YB - yellow-black.

If it was me, I go to a recycler or wrecking yard & source the airbag chassis plug with wires attached. Once you have that, you can splice the wires to the chassis wiring harness in your '04.

You might consider fixing both seats, as the odds are good you'll eventually need to pull the passenger seat out. :icon_eek:

Luckily, you can source the chassis connector from '03-'08 Forester, most likely other model years. :wink:

Bobby...

'03-'04

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

Attachments

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #11 ·
Yep I'm already trying to source a set of plugs w wires. Hopefully the wires are identifiable as to what's what. They just looked yellow on the portion I could see. Hopefully once I get the loom/tape pulled back they are marked. Yes Ill do both. Thanks for the diagram!
 

·
Registered
04 XTI 4EAT-6MT
Joined
·
293 Posts
Discussion Starter · #12 ·
UPDATE:
So I finally had time to install my seats. Had to replace 2 of 4 front bolts, and clean up the passengers side inboard rear bolt. Both drivers side front threads needed re-tapped. New bolts went in like butter.
The wiring was pretty easy but the seat side wires are unmarked, just yellow wires. I did as much homework as I could and went ahead and put connectors in, hoping that I didn't wire something backward and set off the airbag. It all works now, no AIRBAG light and even seat heaters that work on low and high. Definitely appreciate the additional side bolstering and overall feel of the seats. I Want to get the plastic rear bolt covers since they are a different size, but for now, they are good enough.
Thanks for the help!
 
1 - 12 of 12 Posts
Top