Subaru Forester Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2004 X
Joined
·
43 Posts
Discussion Starter · #1 ·
Hey guys, so I recently purchased an 04' XT with 82,000 miles on it. It's been a great car thus far, but when I start it up cold, the power steering is very dodgy when pulling out of the driveway. It also sounds like I'm running over a bag of angry snakes. I checked the PS fluid level and it's where it should be, and appears to be clean. What could cause this? Maybe my PS pump going bad? Once the car warms up, this issue seems to be non existent. :confused:

Also, I've been noticing when I run my XT hard, I notice a foul "burnt" smell coming from the vents whenever I'm in park, or resting at a light for too long. I don't even notice the smell when I'm moving or I have the recirculate function activated. I checked the oil level, and the oil looks clean and is where it should be on the dipstick. We've been getting snow out here in CO, and I've been checking the snow I'm parked over for oil drips, and have found nothing so far. Should I take my car in for a compression test? What's my next step in resolving this?
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,508 Posts
Assuming the the drive belt isn't slipping, perhaps changing PS fluid would help? :confused:

As to the burnt smell. Unless you drop the plastic engine undercover, you can't get a good look under there. The undercover has a diaper like material that can trap & hold lots of oil.

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Premium Member
2009 Fozzie XT Ltd 4EAT
Joined
·
553 Posts
had the same problem on mine

change the belts
 

·
Registered
2003 Forester Auto
Joined
·
22 Posts
Check the o ring on the pump

I had a small problem with the supply line from the ps reservoir to the pump. The o ring at the pump would suck air when cold. The o ring would seal when it got warm...now for the burning smell check for oil leaking onto the exhaust manifold allot of times it won't ever hit the ground.
 

·
Registered
2008 Forester 2.5XT 5MT
Joined
·
25 Posts
I got my 08 recently with similar mileage and noticed the same issues with the PS making noise and cutting out on cold start ups...did a search and figured I'd try tightening the belt first. 30 min reading up on how to do it, 15 min to do it, and problem fixed.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,508 Posts
1 - 8 of 8 Posts
Top