Subaru Forester Owners Forum banner
1 - 12 of 12 Posts

·
Registered
2004 Forester X 2.5L MT
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey everyone,

I'm new to the forums, and I need some assistance.

I just bought an '04 Forester X off some college kid, and well.... he decided to put on a K&N cone filter on the stock air intake. When he did so he mangled to old air box and deleted the MAF sensor along with the wiring harness for it. I manged to find a "new" (junkyard find) airbox with the MAF sensor, and wiring harness. Good news an bad news... The good was finding the parts, bad news is the wiring harness to the MAF connector was cut off at the junk yard.

So now after tons of looking around for how to wire this darn thing up I'm at a loss and looking for anyone to help me with how to wire it. Can anyone out there point me in the right direction of which wires connect where. It's a 4 wire MAF connector.

Anything helps. Thanks in advance.
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,869 Posts
@Prosterize I see this is your first forum post, so welcome to the forum from Oregon! :biggrin:

Perhaps different in Canada, but here in the States, the '04 nonTubo... X is MAP & not MAF.

Forester USDM:
• 98-99 ► MAF
• 2000-2004 NA (nonturbo) ► MAP
• 2004 XT and all 2005+ ► MAF

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
2004 Forester X 2.5L MT
Joined
·
6 Posts
Discussion Starter · #3 ·
Thank Bobby,

I'll look into that a bit more! From what I've found online so far, I was under the impression it had a MAF. So i may be barking up the wrong tree here. My CEL is on and it's running super rich and not burning all the fuel. Smells like a 50's roadster lol. I'll hook it up to a code reader and see what's going on here in the next few days. What's weird is the airbox that came from the junk yard has a MAF on it.... maybe from an older forester? I dont know.

I'll keep you posted with updates on what I find out.

Thanks for getting back to me so quickly.

Kev
 

·
Registered
2004 Forester X 2.5L MT
Joined
·
6 Posts
Discussion Starter · #5 ·
Could be the issue making me even more confused LOL. On my way to Princess Auto for a code reader now. Perhaps it will clarify some things. If i got the wrong airbox, I'll be sure to give em heck ;)
 

·
Registered
2007 Forester XT Manual
Joined
·
319 Posts
I’ll look thru my Subaru service manuals to try and find the wiring schematic for the sensor too. Hope it helps.
 

·
Registered
2004 Forester X 2.5L MT
Joined
·
6 Posts
Discussion Starter · #8 ·
OK here we go.

CEL Codes are :

P0032 - HO2S Heater Control Circuit High Bank 1 Sensor 1
P0447 - Evaporative Emission System Vent Control Circuit Open

This leads me to believe I'm definitely not dealing with any MAF issues Ahaha.

Especially since I look up the part number on the airbox they gave me (Subaru A53AC09) comes back to a 99 outback LOL. Just my luck chasing down a non existent problem!


Thanks Bobby. I may need to re-title this thread now. Duurp
 

·
Registered
2004 Forester X 2.5L MT
Joined
·
6 Posts
Discussion Starter · #9 ·
I’ll look thru my Subaru service manuals to try and find the wiring schematic for the sensor too. Hope it helps.
Thanks Kerby!

The service manual I found online for an '04 Forester LHD Non Turbo model shows a MAF on the wiring harness. SO I'm not sure why it would be there if there is no MAF on a NA. Confusing rabbit hole I've entered.

Kev
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,869 Posts
The model years are different for different countries. What we call an '04 can be an '05 elsewhere. As I noted on my previous post all '05+ are MAF.

If your '04 is RHD, use caution using documentation for the LHD version. :icon_eek:

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]

Bobby...
 

·
Administrator
2007 Forester Sports XT 4EAT
Joined
·
40,869 Posts
OK here we go.

CEL Codes are :

P0032 - HO2S Heater Control Circuit High Bank 1 Sensor 1
P0447 - Evaporative Emission System Vent Control Circuit Open

This leads me to believe I'm definitely not dealing with any MAF issues Ahaha.

Especially since I look up the part number on the airbox they gave me (Subaru A53AC09) comes back to a 99 outback LOL. Just my luck chasing down a non existent problem!


Thanks Bobby. I may need to re-title this thread now. Duurp
The P0032 could be the cause of the engine running too rich. Take a look at this thread: P0032 - Drop Exhaust manifold? - front o2 sensor access - SOLVED!

As to the P0447, take a look at this thread: P0447 Code

Also... I tweaked your thread title. :wink:

Bobby...

['07 FSXT MODding Journal] ['03 X MODding Journal]
 

·
Registered
2004 Forester X 2.5L MT
Joined
·
6 Posts
Discussion Starter · #12 ·
Thanks again!

I'll be sure to give those threads a good look over and get on fixing the problems to get those CEL gone.

Once fixed I'll update this thread.

This car is going to be quite the project, so there may be more threads to come in the future if I can't find any related to what I'll be doing to it. A lot of good info to read over on this site and I'm happy to have it and have come across it.
 
1 - 12 of 12 Posts
Top