Subaru Forester Owners Forum banner
1 - 2 of 2 Posts

·
Registered
2002 S
Joined
·
2,695 Posts
Discussion Starter · #1 ·
I installed this in my car over the weekend by doing the following:
-Reused my stock 02 clockspring
-swapped charge over to STi wheel
-removed my cruise control switch since it doesn't work with my swap anyways.

After I got everything back together the horn didn't work. I know it worked before and I know I didn't kill my clockspring while swapping because I kept it from spinning at all. I also used a puller to get the old wheel off so there's no chance I damaged it by hitting the wheel trying to get it to break loose.

Here is a pic of the switch I removed, can this be part of my problem?
 

·
Registered
2002 S
Joined
·
2,695 Posts
Discussion Starter · #4 ·
From the wiring diagram, the Horn relay is used for both the Cruise activation on that steering wheel switch AND horn activation. So that 3 wire connector has a Green wire with red stripe on it that is not only used for the cruise, but that smaller single spade wire from it is used for the horn switch on the steering wheel.

Since you are not using the cruise and want the horn to work, you must connect pin 1 of the 3 wire connector to that spade lug connection.
The spade goes to a tab here:

You can see where it goes in the bigger picture here:

If I am reading you right, I need to run a wire from the left pin of this connector:

To the tab in the 12 o'clock position of the airbag in this pic(right next to the charge bolt):

Yes? No? Maybe?


THere is a jumper wire that is removed when installing that cruise switch. I think I might have one laying around. PM me if you want/need it.

Bob
What does it actually do? Can you show me a picture?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top