('09-'13) Weird smell from dash defroster...chemical/burning scent? - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 11-22-2010, 07:34 PM   #1 (permalink)
Registered User
 
Laurendaisy's Avatar
 
Join Date: Aug 2010
Posts: 51
Location: CT
Car Year: 2009
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default Weird smell from dash defroster...chemical/burning scent?

Another one to add to the books-

I will have to bring this up when I bring my car to get the weird rattling from the dash (when the temp is under 50'F)--
When I have my front defroster on (I believe that's what it's called) and all the way to "hot" there is a significant and somewhat foul scent- almost like burning chemical smell...only when I have the front defroster on. All the rest of the vents smell a-ok. Has anyone else experienced this? It's significant enough that I have to turn it off because it's nasty.

Just wondering if it's my stellar luck with this car, or if this is common?
Laurendaisy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-23-2010, 03:52 AM   #2 (permalink)
Forum Member
 
trailangel's Avatar
 
Join Date: Aug 2009
Posts: 1,334
Location: Los Angeles
Car Year: 2010
Car Model: Forester 2.5X
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Had that smell when using the heater for a while when car was new... maybe for about 6 months...smelled like new car....almost plastic burning smell.
__________________
TrailAngel
2010 2.5X 5MT
trailangel is offline   Reply With Quote
Old 11-30-2010, 06:38 PM   #3 (permalink)
Registered User
Thread Starter
 
Laurendaisy's Avatar
 
Join Date: Aug 2010
Posts: 51
Location: CT
Car Year: 2009
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by trailangel View Post
Had that smell when using the heater for a while when car was new... maybe for about 6 months...smelled like new car....almost plastic burning smell.
That makes sense...except I bought my car in March of 2009 and it's now Dec. 2010!
Laurendaisy is offline   Reply With Quote
Old 12-01-2010, 05:33 PM   #4 (permalink)
Forum Member
 
BlueBrick's Avatar
 
Join Date: Feb 2006
Posts: 952
Location: 4th Province from the right, Canada
Car Year: 2003
Car Model: Forester X Auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

It's not that stuffed dino head you have sitting on the dash in your avatar pic, is it?
Just checking all possibilities.
__________________
03 X Pacifica Blue Metallic Smooth Brick.
BlueBrick is offline   Reply With Quote
Old 12-01-2010, 06:39 PM   #5 (permalink)
Forum Member
 
TC2000's Avatar
 
Join Date: May 2008
Posts: 3,122
Location: Delmont, Pennsylvania
Car Year: 2009
Car Model: Forester X Premium
Gallery: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by BlueBrick View Post
It's not that stuffed dino head you have sitting on the dash in your avatar pic, is it?
Just checking all possibilities.
LOL

I try not to use the heat all the way on the hot setting...these cars have really, really.. hot heat and i worry it may crack the windshield if its blasted directly up on it when its really cold out. So I try to use it about 3/4 the way give or take abit and that seems to provide plenty of heat and may stop the burning plastic smell.
__________________
2009 Forester X Premium 4EAT

Respect The Wagon!
TC2000 is offline   Reply With Quote
Old 12-05-2010, 03:44 PM   #6 (permalink)
Registered User
Thread Starter
 
Laurendaisy's Avatar
 
Join Date: Aug 2010
Posts: 51
Location: CT
Car Year: 2009
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by BlueBrick View Post
It's not that stuffed dino head you have sitting on the dash in your avatar pic, is it?
Just checking all possibilities.
LOL!! No, that Dino Puppet is not on my dash at all! That picture was taken while on a very long road trip in an FJ... I put him on the dash while my friend was driving and took a pic
Laurendaisy is offline   Reply With Quote
Old 12-05-2010, 03:46 PM   #7 (permalink)
Registered User
Thread Starter
 
Laurendaisy's Avatar
 
Join Date: Aug 2010
Posts: 51
Location: CT
Car Year: 2009
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by TC2000 View Post
LOL

I try not to use the heat all the way on the hot setting...these cars have really, really.. hot heat and i worry it may crack the windshield if its blasted directly up on it when its really cold out. So I try to use it about 3/4 the way give or take abit and that seems to provide plenty of heat and may stop the burning plastic smell.
That's a really good point- the heat is really hot and WONDERFUL () in the cold.... I will keep that in mind. Did I mention I love the heat?
Laurendaisy is offline   Reply With Quote
Old 12-09-2010, 06:40 AM   #8 (permalink)
Forum Member
 
Join Date: Jul 2010
Posts: 19
Location: saratoga NY
Car Year: 2004
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

i have an 04 and just have been noticing the same issue, a weird burning type smell. What would it be causing the smell it does only seem to be when the heat is all the way up...is this like this in all Foresters?
__________________
2004 Forester X
kevbayer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.