power steering pump and hose problems - Subaru Forester Owners Forum
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 1 (permalink) Old 03-19-2007, 09:14 AM Thread Starter
Registered User
 
Join Date: Mar 2007
Location: Manila, Philippines
Posts: 8
Car Year: 2001
Car Model: forester
power steering pump and hose problems

Hi all,
I own a 2001 forester with a 2.0 liter non-turbo, automatic transmission engine. I have logged a little over 100,000 kilometers in it. My power steering pump and hose are leaking, and the local Subaru service dealer recommends replacing both parts. However, it will take time to ship the part to the Philippines. Have any of the forum members encountered this problem, and can anything be done to address the problem without replacing the parts mentioned?
pinoysubie is offline  
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Forester Owners Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome