('06-'08) Poor acceleration - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 12-27-2011, 09:04 AM   #1 (permalink)
Forum Member
 
Inspektor's Avatar
 
Join Date: Jul 2010
Posts: 1
Car Year: 2006
Car Model: Subaru Forester 2.5X
Transmission: 4EAT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default Poor acceleration

Hey guys, got an interesting situation here. First of all, sorry for my English, especially in mechanical terms, hope you will understand everything.


My car specifications:
Model: Forester 2.5X (4AT)
Year: 2006

So two years ago when I bought my Forester it accelerated like hell. Everytime pressing the gas pedal a little harder I was getting pushed back into seat. I could really feel that I drive 129 kW vehicle. However acceleration decreased over time and now it feels like driving 70 kW vehicle.

About a week ago I took my Forester to a local service for some lights adjusting. They somehow discharged my car battery and that caused ECU to reset itself. Interesting thing is that the good old 127 kW acceleration returned then! Too bad after 20-30 minutes of driving it has gone again. Any thoughts?
Inspektor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-27-2011, 09:17 AM   #2 (permalink)
Forum Member
 
FLfrstr's Avatar
 
Join Date: Aug 2009
Posts: 919
Location: Florida
Car Year: 2010
Car Model: Legacy GT LTD
Transmission: 6 spd
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 6 reviews
Default

I would check the condition of your plugs and oxygen sensor.
FLfrstr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:41 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.