DTC PO440 won't clear/self test - Subaru Forester Owners Forum
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 07-25-2012, 03:12 PM Thread Starter
Forum Member
 
Join Date: Jul 2012
Location: Sherwood, OR
Posts: 2
Car Year: 98
Car Model: Imp RS
Transmission: 5 MT
Gallery: 0
Feedback Score: 0 reviews
DTC PO440 won't clear/self test

New to forester.org, but have been on USMB for awhile... Trying this issue out here to see what ya'll think.

1998 Forester 5MT
150,xxx + miles

Charcoal canister replaced
Shut valve replaced (little valve near top of filler neck)
Filler neck replaced (rusted enough to cause a problem soon)

If drain is plugged (removed from frame rail and rubber plug inserted.) system will build pressure to over 1.0" Hg.

My understanding is that the fuel tank pressure should cycle between .250" - .500" Hg when left to idle for a half an hour or so.

Watching the numbers, the pressure cycles, everything looks normal.

The memory has been cleared, 7 of the 8 OBD tests have self checked, Evap emissions still not "ready".

What steps need to be taken to get the computer to check itself off and now pass emissions? (Vehicle was originally tested with PO440 code, thus, evap must be "ready" with no evap codes)

Lewis
2.5gl is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-26-2012, 01:28 PM
Forum Member
 
Join Date: Jul 2012
Posts: 11
Car Year: 2007
Car Model: Forester XT
Transmission: Auto
Gallery: 0
Feedback Score: 0 reviews
Plug green diagnostic connector together and go for a test drive (55mph+, steady throttle (not steady speed), and see if that helps. That should force the test.

Also, you can plug the diagnostic connector with key on/engine off. That will activate all relays and solenoids in vehicle. You can see if the drain valve is even working.
SubTech00 is offline  
post #3 of 5 (permalink) Old 07-26-2012, 01:51 PM
Forum Member
 
Join Date: Feb 2008
Location: N.ID
Posts: 825
Car Year: 2004
Car Model: Forester XT
Transmission: 4EAT
Gallery: 0
Feedback Score: 7 reviews
Well, I know it sounds too easy, but FWIW, have you tried disconnecting the Neg. battery terminal and let it set overnight to fully reset the ECU?
Td

'98 S-Sold
'04 FXT-SOLD
'93 SS-SOLD
'02 GG
wtdash is offline  
post #4 of 5 (permalink) Old 07-26-2012, 02:06 PM Thread Starter
Forum Member
 
Join Date: Jul 2012
Location: Sherwood, OR
Posts: 2
Car Year: 98
Car Model: Imp RS
Transmission: 5 MT
Gallery: 0
Feedback Score: 0 reviews
-> ECU has had it's memory cleared by a SSM3.
-> Battery has been out overnight. (Charging, due to leaving lights and such on too long one day)
-> ECU has been swapped with another car in which all 8 systems were "ready". (Had one available, why not give it a try?)

Car is overdue for registration, trip permit running out, need to get through DEQ.

Yeah, too bad it was taken in to test with CEL/MIL light on, now the EVAP system MUST test "ready" in order to pass.

Have not plugged in D check connectors, was not certain on how to force drive-cycle test. I will give that a go later today or tomorrow. I know it needs to see the correct parameters for it complete the EVAP system test, but it has been months of driving...

Drain valve operating, holding pressure as I blow into it while it cycles. (yes, it holds, and releases, etc...)

Hoses to pressure regulator, canister, shut valve, roll valve, drain valve, purge valve, & filter are all clear.

Thanks guys!

L
2.5gl is offline  
post #5 of 5 (permalink) Old 07-26-2012, 02:18 PM
Forum Member
 
Guerrilla forester's Avatar
 
Join Date: Feb 2012
Location: New York, NY
Posts: 1,100
Car Year: 2003
Car Model: Forester xs
Transmission: Au(to) naturale(/a)
Gallery: 0
Feedback Score: 0 reviews
Evap monitor needs a couple of drives with 50-75% full tank of gas to make its tests, in my experience.
Guerrilla forester is offline  
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Forester Owners Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome