'CRUISE' light flashing - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 12-14-2008, 08:25 AM   #1 (permalink)
Registered User
 
Join Date: Aug 2008
Posts: 4
Location: Canada
Car Year: 2007
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default 'CRUISE' light flashing

I have an recurrent problem with the cruise control on my Forester '07.
It seems to occur on wet days and when I have been in neutral.

The 'CRUISE' light (and ONLY that light - NOT with the check engine) starts to flash and the cruise control cannot be re-engaged until I stop the car and remove the electric power using the key.

Still being on warranty, the dealer tried to troubleshoot it - without success. I read something on a forum about this being related to a neutral switch... Any comment will be greatly appreciated.

Many thanks,

Luc
Barber Pole is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-14-2008, 10:21 AM   #2 (permalink)
Dan
Contributing Member
Supporting Member
 
Dan's Avatar
 
Join Date: Jan 2006
Posts: 4,731
Location: La Crosse area, Wisconsin
Car Year: 12
Car Model: Premium
Transmission: 5-speed
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Since you mentioned wet roads, if ABS or traction control/VDC kicks in, that may be causing the condition. What does the owner's manual for that year have to say about it? IIRC when my neutral switch was giving me trouble, the cruise light never blinked. That's on an '04, though.
__________________
SHIFT_to_Subaru
'12 Forester, 5spd - hers
'08 Legacy SE, 5spd - hers
'09 OB SE, 5spd - mine
Dan is offline   Reply With Quote
Old 12-17-2008, 09:54 PM   #3 (permalink)
Registered User
Thread Starter
 
Join Date: Aug 2008
Posts: 4
Location: Canada
Car Year: 2007
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Unfortunately, the user's manual does not mention about a flashing cruise light.
Barber Pole is offline   Reply With Quote
Old 12-19-2008, 10:31 PM   #4 (permalink)
Forum Member
 
Join Date: Sep 2008
Posts: 10
Location: z
Car Year: 00
Car Model: j
Transmission: j
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Just out of curiosity, what explanation did the dealer give you? I can't see how a dealer can knowingly send a customer back out the door with a car still under warranty with such a blatant issue.
spigot is offline   Reply With Quote
Old 12-24-2008, 09:40 AM   #5 (permalink)
Registered User
Thread Starter
 
Join Date: Aug 2008
Posts: 4
Location: Canada
Car Year: 2007
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

They said they updated the firmware on the car (and crossed their fingers it would work). They also plugged in the laptop while the cruise light flashed and could not read any error code from it.
Barber Pole is offline   Reply With Quote
Old 04-07-2009, 04:25 PM   #6 (permalink)
Registered User
Thread Starter
 
Join Date: Aug 2008
Posts: 4
Location: Canada
Car Year: 2007
Car Model: Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

In case one of you has this problem with the cruise light only flashing, the dealer changed the neutral switch as well as the brake switch and it cleared the problem. Cheers
Barber Pole is offline   Reply With Quote
Old 04-08-2009, 01:12 PM   #7 (permalink)
Forum Member
 
Chilidawg's Avatar
 
Join Date: Mar 2009
Posts: 121
Location: Arcadia, MI
Car Year: 04
Car Model: forester 2.5xs
Transmission: 4EAT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

^^Good info to know. Thank you for the update.
Chilidawg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:51 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.