cruise control problem - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-01-2010, 04:38 PM   #1 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 3
Location: california
Car Year: 2002
Car Model: forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default cruise control problem

After having rountine maintenance done, my cruise control stopped working. Coinsidence perhaps.
When I push the button to engage the cruise the light does not come on and nothing works.
I check the fuse and it is fine.
Any suggestions?
pips is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-01-2010, 05:21 PM   #2 (permalink)
Forum Member
 
Join Date: Jan 2006
Posts: 376
Location: Katy, TX 77493
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

You don't say what year, but on my 99 Forester it's very easy to disconnect the vacuum supply line to the cruise control actuator. I've done it twice at least.

good luck
__________________
See you down the ROW!
1999 Subaru Forester
TexasForester is offline   Reply With Quote
Old 06-01-2010, 09:27 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2009
Posts: 26
Location: Brampton, Ontario
Car Year: 2000
Car Model: Forester L
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Can you point to this vacuum line? I think I have the same issue
Muddy is offline   Reply With Quote
Old 06-02-2010, 08:43 AM   #4 (permalink)
Forum Member
 
Join Date: Jan 2006
Posts: 376
Location: Katy, TX 77493
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Vacuum line connection is on the top of the cruise control actuator near midpoint.

Vacuum line comes from engine intake manifold to the cruise control actuator.

good luck
__________________
See you down the ROW!
1999 Subaru Forester
TexasForester is offline   Reply With Quote
Old 06-07-2010, 07:23 AM   #5 (permalink)
Registered User
Thread Starter
 
Join Date: Jun 2010
Posts: 3
Location: california
Car Year: 2002
Car Model: forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

thank you for the information. I will try it.
pips is offline   Reply With Quote
Old 06-07-2010, 02:25 PM   #6 (permalink)
Registered User
Thread Starter
 
Join Date: Jun 2010
Posts: 3
Location: california
Car Year: 2002
Car Model: forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

OK I looked and didn't have any luck.
My forester is a 2002.
I've been trying to find some sort of engine diagram to give me an idea as to where to look.
Any suggestions as to where to go online to fine this info?
pips is offline   Reply With Quote
Old 06-07-2010, 04:55 PM   #7 (permalink)
Forum Member
 
Join Date: Jan 2006
Posts: 376
Location: Katy, TX 77493
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Couldn't find a pic on site.

My e-manual covers models 99-02 which suggests they are all the same.

Check for linkage (rubber sleeved cable) between throttle plate actuator cam and cruise control actuator. It runs from throttle plate cam behind the throttle body air box to the actuator on the firewall in front of pax seat. Cruise control actuator uses vacuum to pull on the throttle through the cable link.

If you can't find this, you need more help than I can supply.

good luck
__________________
See you down the ROW!
1999 Subaru Forester
TexasForester is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:18 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.