Cruise Control Not Working - Subaru Forester Owners Forum
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 8 (permalink) Old 02-25-2011, 03:43 PM Thread Starter
Registered User
 
Join Date: Feb 2011
Location: New Brunswick
Posts: 8
Car Year: 2002
Car Model: Forester
Gallery: 0
Feedback Score: 0 reviews
Cruise Control Not Working

Two days ago I purchased a 2002 Forester. However, the cruise does not work. When I push the button on the left the light goes on. However, when I pull the lever down nothing happens.

I looked under the dash and I see there is a switch button on both the clutch and the brake - both of these seem fine. However, a few extra plugs up under the dash, likely for options I done have! The suspicious thing is that there are 2 black wires right close to the brake pedal, and on the brake pedal there is a metal pin with a spring on it thats gets depressed when the brake is not pressed...but no switch! Should there be 2 switches on the brake (or clutch)?

Any help would be great.

Thanks.
Potter is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-25-2011, 04:01 PM
Super Moderator
 
good dog's Avatar
 
Join Date: Jan 2006
Location: Dundas, Ontario, Canada
Posts: 8,130
Car Year: 2008
Car Model: XS
Transmission: 4EAT
Gallery: 0
Feedback Score: 0 reviews
First welcome, hope others can contribute to what I have to offer.

I've not had any issues but these posts might help. It appears in the second thread that a neutral switch on the transmission is often the culprit on manual models and is accessible

Cruise control does not work
Does cruise control not work beyond a certain speed?

2008 2.5XS 4EAT
good dog is offline  
post #3 of 8 (permalink) Old 02-25-2011, 07:58 PM Thread Starter
Registered User
 
Join Date: Feb 2011
Location: New Brunswick
Posts: 8
Car Year: 2002
Car Model: Forester
Gallery: 0
Feedback Score: 0 reviews
Wow, I really wonder if it isn't the Neutral Safety Switch. Reason being, on the highway in 5th gear it really lurches, or in any gear really when your holding a constant speed at anything less than 4000 rpm... it needs to be revved up to work well. And, the cruise isn't working. Sound right?
Potter is offline  
post #4 of 8 (permalink) Old 02-25-2011, 08:22 PM
Super Moderator
 
good dog's Avatar
 
Join Date: Jan 2006
Location: Dundas, Ontario, Canada
Posts: 8,130
Car Year: 2008
Car Model: XS
Transmission: 4EAT
Gallery: 0
Feedback Score: 0 reviews
Quick question, when you turn the car on does the CEL light, light up?
I'm pretty sure if the car has an O2 issue it disables the cruise. There is a mod for the O2 sensor to fool the ECU into not showing a CEL. The lurching/bucking could be indicative of a failing O2 sensor. I'll try searching for something tomorrow if no one posts over night.

2008 2.5XS 4EAT
good dog is offline  
post #5 of 8 (permalink) Old 02-26-2011, 11:20 AM Thread Starter
Registered User
 
Join Date: Feb 2011
Location: New Brunswick
Posts: 8
Car Year: 2002
Car Model: Forester
Gallery: 0
Feedback Score: 0 reviews
Yes, the CEL is on, but wasn't always. Cruise wouldn't work and I noticed the lurching, and hour later the CEL came on. I just got the car at an auction so I know no history.
Potter is offline  
post #6 of 8 (permalink) Old 01-13-2012, 05:11 PM
New User
 
Join Date: Jan 2012
Location: North Carolina
Posts: 1
Car Year: 2002
Car Model: SUB Forester
Transmission: 5-sp manual
Gallery: 0
Feedback Score: 0 reviews
Cruise control button

Hi,

I'm new to the forum and recently bought a 2002 Forester with cruise. The problem is that when I press the cruise control button on the dash, it doesn't light or seem to engage. It just pops up without staying down. Needless to say the cruise control doesn't work with it the way it is. Any ideas where to look first? Is it the button or something else causing the problem?

Thanks for your help. I've already learned some things about the Forester on this forum. I'm returning to Subaru after a 3-yr hiatus with a Nissan. I had an Impreza before the Nissan until someone ran a red light and totaled it.
lexforester5 is offline  
post #7 of 8 (permalink) Old 04-11-2012, 09:05 AM
Forum Member
 
Join Date: Apr 2012
Location: Washington State
Posts: 12
Car Year: 2000
Car Model: Forester L
Transmission: Manual 5spd
Gallery: 0
Feedback Score: 0 reviews
I'm having the same issue. It was after I had transmission work done, the cruise control never worked again. I have a 2000 forester L 5spd. The CEL is on, but it's for the Catalytic converter. I already changed both O2 sensors as those went out right after I bought it (probably just a odb2 format the day I bought it).

I can press the Cruise button on the left, it lights up. The toggle doesn't engage anything though. How do I know if the Neutral Safety Switch is the issue? How do I test it?
Libertatus is offline  
post #8 of 8 (permalink) Old 05-24-2014, 10:44 PM
Forum Member
 
Join Date: May 2014
Location: Madison, IN
Posts: 18
Car Year: 2002
Car Model: Forester
Transmission: 5 speed
Gallery: 0
Feedback Score: 0 reviews
Unhappy Light on curise control does not come on=no cruise

Seems I'm having a common problem on my 02 Forester. The Cruise Control!

When I press the cruise control button no light comes on, thus the cruise is not working.
All the fuses seem to be good.
Vacuum line is good.

I checked the clutch switches, one has no wire attached, would that be normal? I'm not real sure what to look for here.

I also noticed there are two green connectors not attached underneath the dash, any thoughts on that?
From what I've read if the light is not coming on the switch is not working. Seems I need to start there. Does anyone know what exactly I need to look for to see why the switch is not working.

Thanks!
Krobert is offline  
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Forester Owners Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome